Closed Bug 770492 Opened 8 years ago Closed 7 years ago

Quick sliding to close tabs will not dismiss them anymore at some point

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 19
Tracking Status
firefox16 --- affected
firefox17 --- affected
firefox18 --- affected
firefox19 --- verified
fennec 19+ ---

People

(Reporter: xti, Assigned: lucasr)

Details

(Whiteboard: ui-responsiveness)

Attachments

(3 files)

Attached image screenshot
Firefox 16.0a1 (2012-07-03)
Device: Galaxy Nexus, Asus TF 101
OS: 4.0.2, 4.0.3

Steps to reproduce:
1. Open Fennec
2. Browse to popuptest.com/popuptest1.html
3. Dismiss the doorhanger by tapping on "Always Show" button
4. Refresh the page opened at step 2
5. After all popups are loaded, switch to the tab from step 2
6. Repeat steps 4-5 until there will be at least 30+ tabs opened
7. Open the Tab Menu and slide do close tabs as quick as you can

Expected results:
All tabs will be closed, except the default one.

Actual result:
At some point, tabs are not closed any more and some UI issues can be easily noticed in Tabs Menu (see attached screenshot)
tracking-fennec: --- → ?
This also reproducible on:
Firefox Mobile 16 beta 6 build 2
Aurora 17.0a2 (2012-09-04)
Nightly 18.0a1 (2012-09-04)
Device: Samsung Galaxy Tab (Android 3.1)
Does using the "x" also cause this problem?
Assignee: nobody → wjohnston
tracking-fennec: ? → -
The issue is not reproducible using 'x' to close tabs
Whiteboard: ui-responsiveness
I've been running into this a lot recently - perhaps a side effect of Lucas's UI responsiveness bugs?

STR:
1) Have at least 3 tabs open
2) Close one tab
3) While the animation is going, close another tab

The tab from #3 gets stuck (see screenshot), and you can't interact with it. You have to close and reopen the tabs tray.
Re-nom'ing since this is now much easier than described in comment 0.
tracking-fennec: - → ?
(In reply to Brian Nicholson (:bnicholson) from comment #4)
> STR:
> 1) Have at least 3 tabs open
> 2) Close one tab
> 3) While the animation is going, close another tab

Note that you have to close the tabs by swiping.
Does this bug still happen brian?
Flags: needinfo?(bnicholson)
Assignee: wjohnston → lucasr.at.mozilla
(In reply to Wesley Johnston (:wesj) from comment #7)
> Does this bug still happen brian?

Yep - using the STR in comment 4, I see this in the current Nightly.
Flags: needinfo?(bnicholson)
tracking-fennec: ? → 19+
Attachment #676339 - Flags: review?(mark.finkle)
Attachment #676339 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/fcaa13a3a48e
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
I cannot reproduce this issue anymore on the latest Nightly build. Closing bug as verified fixed on:

Firefox 19.0a1 (2012-11-13)
Device: Galaxy S2
OS: Android 4.0.3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.