Intermittent image-preserveAspectRatio-03.svg | image comparison (==)

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Mac OS X
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 638697 [details]
reftest log

Rev3 MacOSX Leopard 10.5.8 mozilla-inbound opt test reftest on 2012-07-03 05:33:27 PDT for push d8a4ef92f06e

slave: talos-r3-leopard-015

https://tbpl.mozilla.org/php/getParsedLog.php?id=13191142&tree=Mozilla-Inbound

{
REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/svg/image/image-preserveAspectRatio-03.svg | 5927 / 8001 (74%)
REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/svg/image/image-preserveAspectRatio-03-ref.svg | 5927 / 8001 (74%)
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/svg/image/image-preserveAspectRatio-03.svg | image comparison (==)
REFTEST number of differing pixels: 464 max difference: 255
}
The difference here is in the bottommost <image> element, which has preserveAspectRatio="defer" on it.

The SVG file that it points to has an animation that gives itself preserveAspectRatio="none" (which we should honor, because we're "defer").  That change is supposed to trigger an invalidation of that <image> element and stretch the rendering to fill the <image>'s viewport (the dashed box).

However, that's not happening in the testcase. We're rendering the image as if it didn't have that internal preserveAspectRatio="none".

I can actually reproduce this locally in my nightly, by loading (and full-reloading) http://hg.mozilla.org/mozilla-central/raw-file/f38d6df93cad/layout/reftests/svg/image/image-preserveAspectRatio-03.svg
The initial rendering has the lowermost image as a right-aligned square (incorrect). If I switch tabs away & back, then it re-renders as a stretched rectangle, filling its dashed box. (correct)
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.