desktop b2g gecko builds should be able to start by double clicking 'b2g'

RESOLVED FIXED

Status

Firefox OS
General
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jhford, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: b2g-desktop-builds)

When you start up B2G on Mac or Linux, you'll likely experience an issue with the dynamic library loader being unable to find required libraries.  This is because the library loader does not know where to look for the libraries.

The way we solve this for Firefox on Mac and Linux is to have a script that is $(MOZ_APP_NAME), and name the actual program file $(MOZ_APP_NAME)-bin.  The script essentially figures out which directory the binary and it's libraries are located then runs the program using an LD_LIBRARY_PATH or DYLD_LIBRARY_PATH equal to the directory that the libraries are located.

Lets modify B2G so that on Unixish OSs, we create a 'b2g' script and a 'b2g-bin' executable file.

This was discovered at the same time as bug 770628, but these are two different bugs which happen to both result in the same basic error message of the library loader being unable to find a library.  770628 is the result of us not packaging a specific dylib file.
fwiw, on ubuntu 12.04, clicking the b2g executable works.
This is working on Mac.  I'm going to try to reproduce on Fedora, but it looks like this is likely a RESO->INVALID bug.
(In reply to John Ford [:jhford] from comment #2)
> This is working on Mac.

Working on Mac with the bug 770628 patch you mean?
(In reply to Dietrich Ayala (:dietrich) from comment #3)
> (In reply to John Ford [:jhford] from comment #2)
> > This is working on Mac.
> 
> Working on Mac with the bug 770628 patch you mean?

yes.  The mac dynamic library loader is able to figure out where the libraries are without using DYLD_LIBRARY_PATH.  The issue that this bug was filed for is not an issue on Mac.
Priority: -- → P1

Comment 5

6 years ago
using whiteboard "b2g-desktop-builds" for ease of tracking
Whiteboard: b2g-desktop-builds
Is this fixed now?
yes
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.