Marketplace search input field can not be selected on the current Nightly, was working in past Nightlys and current FF Beta Release

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Steps:

1. Go to marketplace.mozilla.org
2. Login with browser ID
3. Select the search input field to input text

Expected:

The text cursor should show to allow the user to input text into the search text field.

Actual:

The button to complete the search is executed instead.

Demo:

See http://screencast.com/t/475pFF2p.
(Reporter)

Comment 1

7 years ago
k9o & tracking-firefox16 nomination - search is a pretty basic piece to marketplace functionality, and we know it "was" working in past Nightlys and in the current FF Beta 14 release.
blocking-kilimanjaro: --- → ?
tracking-firefox16: --- → ?
Keywords: regression
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

7 years ago
Getting the regression range now. So far:

6/28/2012 - Working

7/2/2012 - Busted
(Reporter)

Comment 3

7 years ago
Got the regression range down to the date.

Last Working:

6/30/2012 Nightly build

First Failed:

7/1/2012 Nightly build

Changelog:

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=6%2F30%2F2012&enddate=7%2F1%2F2012
(Reporter)

Updated

7 years ago
Keywords: regressionwindow-wanted
Maybe Bug 767169 ?
Duplicate of this bug: 770913
So, could anyone test whether Bug 767169 caused this?
Cannot reproduce on m-c at 675f55c4310c, nor in nightly 2012-07-05.  Logging in and clicking in the search box behaves as expected: it's focused and allows text input, and clicking the arrow works as expected.  Am I not understanding the repro instructions?  Or maybe the site was changed?
(Reporter)

Comment 8

7 years ago
(In reply to :Aryeh Gregor from comment #7)
> Cannot reproduce on m-c at 675f55c4310c, nor in nightly 2012-07-05.  Logging
> in and clicking in the search box behaves as expected: it's focused and
> allows text input, and clicking the arrow works as expected.  Am I not
> understanding the repro instructions?  Or maybe the site was changed?

Strange. I can't reproduce anymore either. Marking as such. I'll keep a look out if I see this happen again though.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

7 years ago
blocking-kilimanjaro: ? → ---
tracking-firefox16: ? → ---
The word on the street was something was backed out. And yeah looks great to me now too.
I agree this works now.  In case we need another test case in the future, this was also seen on bhphotovideo.com
You need to log in before you can comment on or make changes to this bug.