Last Comment Bug 770812 - Merge nsIEditorSupport into nsEditor
: Merge nsIEditorSupport into nsEditor
Status: RESOLVED FIXED
[mentor=ehsan][lang=c++]
: dev-doc-needed
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: mozilla16
Assigned To: Sankha Narayan Guria [:sankha]
:
Mentors:
Depends on:
Blocks: 769967
  Show dependency treegraph
 
Reported: 2012-07-04 01:54 PDT by :Aryeh Gregor (away until August 15)
Modified: 2012-07-12 09:37 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
merged nsIEditorSupport into nsEditor (6.63 KB, patch)
2012-07-11 02:28 PDT, Sankha Narayan Guria [:sankha]
no flags Details | Diff | Review
Patch to just delete the nsIEditorSupport interface (2.85 KB, patch)
2012-07-11 09:04 PDT, Sankha Narayan Guria [:sankha]
ehsan: review+
Details | Diff | Review

Description :Aryeh Gregor (away until August 15) 2012-07-04 01:54:10 PDT
The file editor/libeditor/base/nsIEditorSupport.h is unnecessary.  Nothing uses the interface, and the only thing that's derived from it is editor/libeditor/base/nsEditor.h.  It should be merged into nsEditor and deleted.

(See bug 769967 comment 8.)
Comment 1 Sankha Narayan Guria [:sankha] 2012-07-07 23:38:23 PDT
Can you assign me the bug? I would like to work on it.
Comment 2 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-09 15:05:10 PDT
Sure!
Comment 3 Sankha Narayan Guria [:sankha] 2012-07-11 02:28:26 PDT
Created attachment 640984 [details] [diff] [review]
merged nsIEditorSupport into nsEditor
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-11 07:23:46 PDT
Comment on attachment 640984 [details] [diff] [review]
merged nsIEditorSupport into nsEditor

Review of attachment 640984 [details] [diff] [review]:
-----------------------------------------------------------------

::: editor/libeditor/base/nsEditor.h
@@ +8,5 @@
>  
>  #include "nsCOMPtr.h"
>  #include "nsWeakReference.h"
>  
> +#include "nsISupports.h"

This shouldn't be needed, there are tons of other headers including this one.

@@ +76,5 @@
> +
> +/**
> + * Private Editor interface for a class that can provide helper functions
> + */
> +class nsIEditorSupport  : public nsISupports {

Hmm, I think I wasn't quite clear on what I would like us to achieve in this bug.  nsIEditorSupport is a completely useless interface, and we should remove it completely.

So after taking a closer look, it turns out that nothing in mozilla-central even #includes this header, so you can just remove that header, and that would be all that needs to be done in this bug!  :-)
Comment 5 Sankha Narayan Guria [:sankha] 2012-07-11 09:04:06 PDT
Created attachment 641073 [details] [diff] [review]
Patch to just delete the nsIEditorSupport interface
Comment 6 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-11 15:02:57 PDT
Comment on attachment 641073 [details] [diff] [review]
Patch to just delete the nsIEditorSupport interface

Super!
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-11 15:06:50 PDT
Landed with a proper commit message, thanks!

https://hg.mozilla.org/integration/mozilla-inbound/rev/fd0f3b5283d4
Comment 8 Ed Morley [:emorley] 2012-07-12 09:37:26 PDT
https://hg.mozilla.org/mozilla-central/rev/fd0f3b5283d4

Note You need to log in before you can comment on or make changes to this bug.