Thunderbird win64 is crashed without crashreporter running

RESOLVED DUPLICATE of bug 763361

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 763361
6 years ago
6 years ago

People

(Reporter: Takanori MATSUURA, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86_64
Windows 7
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

35.55 KB, text/plain
Details
(Reporter)

Description

6 years ago
Win64 version of tb 16.0a1 is crashed during quitting.

These crashes are occurred without crashreporter running. So there is no reports at https://crash-stats.mozilla.com/
(Reporter)

Comment 1

6 years ago
I can provide WERInternalMetadata.xml, appcompat.txt, and mdmp files if someone need them.
does it crashes everytime you quit ?

if so can you get us a stack trace with windbg ? as per https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg ?
(Reporter)

Comment 3

6 years ago
I'm not familiar to Windows development environment.

Which tools do I have to get? I use 64 bit Tb on 64 bit windows. In this case, do I have to use 64 bit tools?
http://msdn.microsoft.com/en-us/windows/hardware/gg463009/

Comment 5

6 years ago
debugger works fine in 64 bit. just make sure you get thunderbird symbols per https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 6

6 years ago
Created attachment 639204 [details]
Debug log
(In reply to Takanori MATSUURA from comment #6)
> Created attachment 639204 [details]
> Debug log

Matsuura-san, please set debug symbol path (or _NT_SYMBOL_PATH environment value) like the following.  You don't set it, so I cannot analyze your report.

0:035> .sympath
Symbol search path is: SRV*C:\localsym*http://msdl.microsoft.com/download/symbols;SRV*C:\localsym*http://symbols.mozilla.org/firefox;SRV*C:\localsym*http://symbols.mozilla.org/thunderbird
(Reporter)

Comment 8

6 years ago
(In reply to Makoto Kato from comment #7)

I set .sympath like the following. However I got an error message:
Opened log file 'c:\Users\matsuura\firefox-debug_09bc_2012-07-05_09-42-24-125.log'

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

CommandLine: "C:\Program Files\Daily\thunderbird.exe"
Symbol search path is: SRV*c:\symbols*http://symbols.mozilla.org/firefox;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols;srv*
Executable search path is: 
ModLoad: 00000001`3f960000 00000001`3f9c2000   thunderbird.exe
ModLoad: 00000000`775d0000 00000000`77779000   ntdll.dll
ModLoad: 00000000`774b0000 00000000`775cf000   C:\windows\system32\kernel32.dll
ModLoad: 000007fe`fdb40000 000007fe`fdbac000   C:\windows\system32\KERNELBASE.dll
ModLoad: 00000000`74de0000 00000000`74e75000   C:\windows\System32\SYSFER.DLL
ModLoad: 00000000`773b0000 00000000`774aa000   C:\windows\system32\USER32.dll
ModLoad: 000007fe`ff4a0000 000007fe`ff507000   C:\windows\system32\GDI32.dll
ModLoad: 000007fe`ff3e0000 000007fe`ff3ee000   C:\windows\system32\LPK.dll
ModLoad: 000007fe`fef80000 000007fe`ff049000   C:\windows\system32\USP10.dll
ModLoad: 000007fe`fecc0000 000007fe`fed5f000   C:\windows\system32\msvcrt.dll
ModLoad: 00000000`74830000 00000000`74901000   C:\Program Files\Daily\MSVCR100.dll
(6bc.dac): Break instruction exception - code 80000003 (first chance)
ntdll!LdrpDoDebuggerBreak+0x30:
00000000`7767cb60 cc              int     3
0:000> .sympath SRV*c:\symbols*http://symbols.mozilla.org/thunderbird;SRV*c:\symbols*http://symbols.mozilla.org/firefox;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
Symbol search path is: SRV*c:\symbols*http://symbols.mozilla.org/thunderbird;SRV*c:\symbols*http://symbols.mozilla.org/firefox;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
Expanded Symbol search path is: srv*c:\symbols*http://symbols.mozilla.org/thunderbird;srv*c:\symbols*http://symbols.mozilla.org/firefox;srv*c:\symbols*http://msdl.microsoft.com/download/symbols
0:000> .symfix+ c:\symbols
0:000> .reload /f
Reloading current modules
..*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\windows\System32\SYSFER.DLL - 
....*** WARNING: Unable to verify checksum for thunderbird.exe
.....
(In reply to Takanori MATSUURA from comment #8)

> Reloading current modules
> ..*** ERROR: Symbol file could not be found.  Defaulted to export symbols
> for C:\windows\System32\SYSFER.DLL - 

There is no SYSFER.pdb in MS symbols server.  Please ignore this.

> ....*** WARNING: Unable to verify checksum for thunderbird.exe
> .....

I think that you can load symbols correctly.  (please ignore checksum warning).

Could you create debug log with this setting?
(Reporter)

Comment 10

6 years ago
Created attachment 639230 [details]
Debug log

Re-create debug log.
Attachment #639204 - Attachment is obsolete: true
Thanks, Matsuura-san.

This is same as bug 763361.  Since process exiting (and free kernel32.dll), I think that crash reporter cannot handle this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763361
You need to log in before you can comment on or make changes to this bug.