Closed Bug 770850 Opened 9 years ago Closed 9 years ago
Or Header should be called Definition List
ParseMaps.h is a big improvement over the prior situation, but parts of its implementation are pretty baffling. In particular, there's a nicer way to express what DefnOrHeader is doing.
Assignee: general → jorendorff
Attachment #639063 - Flags: review?(n.nethercote)
Handy cheat sheet: DefnOrHeader --> DefinitionList AtomDeclNode --> DefinitionList::Node MultiDeclRange --> DefinitionList::Range doh.isHeader() --> dlist.isMultiple() AtomDOHMap --> AtomDefnListMap
Attachment #639063 - Flags: review?(n.nethercote) → review+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16
You need to log in before you can comment on or make changes to this bug.