Password Manager "Remember password checkbox is unchecked after restart"

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
6 years ago
a year ago

People

(Reporter: kesselhut, Unassigned)

Tracking

SeaMonkey 2.10 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120604 Firefox/13.0 SeaMonkey/2.10
Build ID: 20120604225435

Steps to reproduce:

Activating of Password Manager work only for the activ user session.


Actual results:

Remember password checkbox is unchecked after restart of Seamonkey.




Expected results:

The Remember password checkbox should checked constantly.
(Reporter)

Updated

6 years ago
Severity: normal → minor
(Reporter)

Updated

6 years ago
Summary: Password Manager → Password Manager "Remember password checkbox is unchecked after restart"

Comment 1

6 years ago
WFM here
Build identifier: Mozilla/5.0 (Windows NT 5.2; rv:13.0) Gecko/20120615 Firefox/13.0.1 SeaMonkey/2.10.1
Open about:support, press Show folder, close SeaMonkey, find file prefs.js, open it with notepad and find two preferences, signon.rememberSignons (must be true) and  signon.SignonFileName (must be file name specified). If not, add them and set accordingly.
(Reporter)

Comment 2

6 years ago
(In reply to Phoenix from comment #1)
> WFM here
> Build identifier: Mozilla/5.0 (Windows NT 5.2; rv:13.0) Gecko/20120615
> Firefox/13.0.1 SeaMonkey/2.10.1
> Open about:support, press Show folder, close SeaMonkey, find file prefs.js,
> open it with notepad and find two preferences, signon.rememberSignons (must
> be true) and  signon.SignonFileName (must be file name specified). If not,
> add them and set accordingly.

Hello WFM,

user_pref("signon.rememberSignons", true); is deleted in prefs.js at the startup of Seamonkey.
It seems a failure in version 2.10, the  version 2.8 has no problem.

Comment 3

6 years ago
Is second variable specified? If not, do you have write rights to profile dir?
(Reporter)

Comment 4

6 years ago
Second variable is defined, write rights to profile is ok.
(Reporter)

Comment 5

6 years ago
The problem was the autoconfig. The user config is reset by the setting defaultPref("signon.rememberSignons", false);

similar Bug 451161 - defaultPref overwrites user prefs
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451161

Comment 7

6 years ago
> user_pref("signon.rememberSignons", true); is deleted in prefs.js

That is normal.
That Pref only exists if it is unchecked, set to "false".
When set to true, is removes itself from prefs.js.
 
 
Might you have that Pref hardcoded in a user.js file?
 
 
As a test, if you create a new Profile, it the setting remembered correctly?
 
 
BTW:
Edit | Preferences | Privacy & Security -> Passwords

(Sure would be nice if Preferences Panel remembered where you last were so you didn't have to drill back down again & again ;-).)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

6 years ago
> Might you have that Pref hardcoded in a user.js file?
>  
>  
> As a test, if you create a new Profile, it the setting remembered correctly?

Yes, I have defined a default configuration in a general config file and set "signon.rememberSignons" to "false". 

If the user set "signon.rememberSignons" to "true", it's deleted from prefs.js and at the next start the user get the global default config of "signon.rememberSignons" again.

Comment 9

a year ago
Is this still present in latest SeaMonkey version?
Flags: needinfo?(kesselhut)
Whiteboard: [closeme 2017-05-15]
(Reporter)

Comment 10

a year ago
No, It seems to be fixed in 2.46.
Flags: needinfo?(kesselhut)

Comment 11

a year ago
Thank you for the reply
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years agoa year ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2017-05-15]
You need to log in before you can comment on or make changes to this bug.