Instead of graying out the "installed" button saying "installed" when an app is installed, keep it blue with the word "re-install" to allow reinstall of a web app

RESOLVED DUPLICATE of bug 710062

Status

RESOLVED DUPLICATE of bug 710062
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

6 years ago
The current marketplace approach when an app is installed is to show a greyed out a button that says installed. Further visits will continue to show the button as such, which encourages no user interaction to reinstall the app.

Reinstalling an app is a valid use case for managing web applications, as there are cases where users may need to reinstall web apps in cases such as:

- I deleted my desktop shortcut on windows, but I want to get it back
- The app manifest for that app has changed, possibly requiring a reinstall to get the update

The solution I'd suggest here is to instead show "re-install" in a blue color when we know the app is installed, instead of showing a grey button with installed. That way, we end up sending the message to users that they can re-install apps already installed through the marketplace.
This could be considered a dupe of bug 710062. And Maria, in bug 747144 comment 12, recommended we say "Open" to launch the app.

There's been a lot of discussions over what the buttons should say, and let's try to first make the modifications Maria has suggested.
(Reporter)

Comment 2

6 years ago
(In reply to Chris Van Wiemeersch [:cvan] from comment #1)
> This could be considered a dupe of bug 710062. And Maria, in bug 747144
> comment 12, recommended we say "Open" to launch the app.

Ah okay. That's fine too, although note desktop support for launching the app hasn't landed yet (it's a P1 though and definitely on our radar for FF 16, so it will be fixed soon). Note that I should note that the high-level goal of what I'm mentioning is to have to someway to point a user to "hey, here's how you reinstall the app."
(Reporter)

Comment 3

6 years ago
Let's dup on that bug then.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 710062
You need to log in before you can comment on or make changes to this bug.