Geolocation popup notification seen even though Allow radio button was checked under Tools | Page -> Permission ->Share location

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: send2diwakar, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20120703 Firefox/15.0a2
Build ID: 20120703042007

Steps to reproduce:

Browser version: Aurora 15.0a2

OS Version : Windows 7 32-bit

Steps to reproduce the issue:

1) Start Firefox with a new profile
2) Go to Tools | Page Info and select the Permission tab.
3) Under "Share Location", uncheck "Always Ask" and select the radio button that says "Allow"
4) Visit http://mozqa.com/data/firefox/geolocation/position.html


Actual results:

1) After step 4 When the site (http://mozqa.com/data/firefox/geolocation/position.html) was opened the Geolocation popup notification was seen again even though in step 3  "Allow" radio button was checked .

2) At Page info -> Permissions , Under "Share Location"  ->  "Always Ask"  radio button was checked again


Expected results:

You should not see a Geolocation popup notification when loading the test site
(Reporter)

Updated

6 years ago
Priority: -- → P3
(Reporter)

Updated

6 years ago
Component: Untriaged → Page Info

Comment 1

6 years ago
Only recent change I can see is:
Bug 758357 - Only show prompt after 50mb of quota was reached
But it was backed out due to:
Bug 770085 - b2g-desktop builds broken by Bug 758357
(In reply to Diwakar Sharma from comment #0)
> 2) Go to Tools | Page Info and select the Permission tab.
> 3) Under "Share Location", uncheck "Always Ask" and select the radio button
> that says "Allow"
> 4) Visit http://mozqa.com/data/firefox/geolocation/position.html

Umm, I don't get it: Page Info (and e.g. its Permissions Tab) is bound to a certain Site - the one you're invoking the Info on.

So in Step 2) what Site is named at the Top ("Permissions for: xxxx") of the Permissions Tab?
Page Info permissions are bound to the site loaded in the current tab, as pointed out in comment 2. I would only consider this to be a bug if you are continued to be asked to allow after following:

1. Load http://mozqa.com/data/firefox/geolocation/position.html
2. Click "Always Share Location"
3. Reload the page in step 1

- or -

1. Load http://mozqa.com/data/firefox/geolocation/position.html
2. Click "Share Location"
3. View Page Info > Permissions
4. Uncheck "Always Ask" and select "Allow"
5. Reload the page

There is no global sharing permissions as far as I am aware.
Component: Page Info → Geolocation
OS: Windows 7 → All
Product: Firefox → Core
Hardware: x86 → All
Version: 15 Branch → Trunk
(Reporter)

Comment 4

6 years ago
Hi Anthony,


you can junk this bug i don't see this happening now 

Regards,
Diwakar
Thanks Diwakar, resolving WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.