Closed Bug 770974 Opened 12 years ago Closed 12 years ago

[de] Firefox 15 localization into German

Categories

(Mozilla Localizations :: de / German, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aryx, Assigned: aryx)

Details

Attachments

(3 files, 1 obsolete file)

This bug is for the localization of Firefox 15 into German.
Note that I plan to fix the toolkit/ parts within the next hour, so let's do only the browser/ parts here.
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #640003 - Flags: review?(kairo)
Attachment #640003 - Flags: review?(a.topal)
Ok, so this is the German localization for Firefox 15. I hadn't yet time to test it, if you can put on hands on it before me, that would be nice.
Neuer Patch mit einigen Korrekturen, beim Remote Debugger und der Entwicklersymbolleiste habe ich nicht alle Übersetzungen überprüfen können.

Kommentare, die schon beim letztn Mal hätten dabei sein sollen:

aboutDialog.dtd:
<!ENTITY update.applying            "Applying update…">
<!ENTITY update.applying            "Update wird angewendet…">
Seid Ihr damit einverstanden? Hintergrund: Es wird ein neues, temporäres Anwendungsverzeichnis erstellt, in dem die Anwendung mit der neuen Version erstellt wird. Erst bei einem Neustart der Anwendung ersetzt die neue die alte Anwendung.

Das betrifft auch die browser.properties:
update.restart.updateButton.label=Restart to apply
update.restart.updateButton.label=Zum Anwenden neu starten
update.restart.updateButton.accesskey=A

devtools\debugger.dtd
<!ENTITY remoteDebuggerMenu.label    "Remote Debugger">
<!ENTITY remoteDebuggerMenu.label    "Netzwerk-Debugger">


Beim internen PDF-Viewer habe ich mich daran orientiert, was meiner Meinung nach am besten passt und nicht am Adobe Reader (z.B. "Lesezeichen" vs. "Dokumentstruktur", englisch ist es "document structure").
Attachment #640003 - Attachment is obsolete: true
Attachment #640003 - Flags: review?(kairo)
Attachment #640003 - Flags: review?(a.topal)
Attachment #640088 - Flags: review?(kairo)
Attachment #640088 - Flags: review?(a.topal)
Comment on attachment 640088 [details] [diff] [review]
Firefox 15 German localization, patch v3

Review of attachment 640088 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/chrome/browser/browser.dtd
@@ +98,4 @@
>  <!ENTITY fullScreenExit.accesskey "V">
> +<!ENTITY fullscreenAllowButton.label "Erlauben">
> +<!ENTITY fullscreenExitButton.label "Ablehnen">
> +<!ENTITY fullscreenApproval.value "Wollen Sie den Wechsel zu Vollbild erlauben?">

Der Satz klingt holprig für mich, mit dem "zu Vollbild". Aber ich hab keine bessere Idee.

@@ +235,5 @@
>  <!ENTITY styleeditor.accesskey        "S">
>  <!ENTITY styleeditor.keycode          "VK_F7">
>  <!ENTITY styleeditor.keytext          "F7">
>  
> +<!ENTITY inspectCloseButton.tooltiptext "Untersuchung beenden">

Hmm, ob "Untersuchung" für Web-Entwickler klar zum "Inspector" deutet, über den sie in den oft englischpsprichigen Artikeln lesen, weiß ich nicht. Für "Otto Normalverbraucher" würde ich diese Idee gut finden, für Web-Entwickler, auf die diese Funktion zielt, bin ich mir nicht so sicher.

::: browser/chrome/browser/devtools/debugger.properties
@@ +28,5 @@
> +remoteDebuggerPromptMessage=Hostname und Portnummer eingeben (Format: Host:Port)
> +
> +# LOCALIZATION NOTE (remoteDebuggerPromptCheck): The message displayed on the
> +# debugger prompt asking if the prompt should be shown again next time.
> +remoteDebuggerPromptCheck=Mich nicht mehr fragen

Ich würde "Nicht mehr nachfragen" verwenden.

::: browser/chrome/browser/devtools/scratchpad.properties
@@ +39,5 @@
>  
>  # LOCALIZATION NOTE  (scratchpadIntro): This is a multi-line comment explaining
>  # how to use the Scratchpad. Note that this should be a valid JavaScript
>  # comment inside /* and */.
> +scratchpadIntro=/*\n * Dies ist eine JavaScript-Umgebung.\n *\n * Geben Sie etwas JavaScript ein und führen Sie einen Rechtsklick aus oder wählen Sie aus dem Auführen-Menu:\n * 1. Ausführen, um den ausgewählten Text zu evaluieren,\n * 2. Untersuchen, um den Objekt-Inspektor auf das Resultat anzuwenden,\n * 3. Anzeigen, um das Ergebnis in einen Kommentar hinter der Auswahl einzufügen.\n */\n\n

Ah, und da ist es ein "Inspektor". ;-)

::: browser/chrome/browser/devtools/webconsole.properties
@@ +184,5 @@
> +# LOCALIZATION NOTE (JSTerm.updateNotInspectable):
> +# This string is used when the user inspects an evaluation result in the Web
> +# Console and tries the Update button, but the new result no longer returns an
> +# object that can be inspected.
> +JSTerm.updateNotInspectable=Nach der Reevaluierung der Eingabe ist das Ergebnis nicht länger untersuchbar.

Das Doppel-e sieht hier komisch aus. Ist "Re-Evaluierung" besser?

::: browser/chrome/browser/safeMode.dtd
@@ +41,2 @@
>  
> +<!ENTITY startSafeMode.label          "Im Abgesicherten Modus starten">

Hmm, ist der als Eigenname zu betrachten? Ich würde hier Kleinschreibung verwenden...

@@ +49,4 @@
>  
> +<!-- LOCALIZATION NOTE (autoSafeModeDescription2.label safeModeInstead.label resetProfileFooter.label): Shown on the safe mode dialog after multiple startup crashes. See also chrome/global/resetProfile.dtd -->
> +<!ENTITY autoSafeModeDescription2.label "&brandShortName; wurde unerwartet beendet. Dies kann durch Add-ons oder andere Probleme verursacht werden. Sie können versuchen, das Problem zu beheben, indem Sie &brandShortName; in den Ausgangszustand zurückversetzen lassen oder selbst versuchen, das Problem im Abgesicherten Modus zu beseitigen.">
> +<!ENTITY resetProfileFooter.label       "Alles Andere wird in die Ausgangseinstellungen zurückversetzt.">

"Andere" oder "andere"?
Attachment #640088 - Flags: review?(kairo) → review+
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #7)
> > +<!ENTITY fullscreenApproval.value "Wollen Sie den Wechsel zu Vollbild erlauben?">
> 
> Der Satz klingt holprig für mich, mit dem "zu Vollbild". Aber ich hab keine
> bessere Idee.
Habe es zu "Wollen Sie den Wechsel in den Vollbild-Modus erlauben?" geändert.

> > +<!ENTITY inspectCloseButton.tooltiptext "Untersuchung beenden">
> 
> Hmm, ob "Untersuchung" für Web-Entwickler klar zum "Inspector" deutet, über
> den sie in den oft englischpsprichigen Artikeln lesen, weiß ich nicht. Für
> "Otto Normalverbraucher" würde ich diese Idee gut finden, für
> Web-Entwickler, auf die diese Funktion zielt, bin ich mir nicht so sicher.
Letzten Endes sollen die Hilfeseiten alle in Deutsch sein. Über eine Umbenennung der Funktion lasse ich mit mir reden ("Untersuchen" gab es schon länger als Eintrag im Menü "Web-Entwickler"), auch über "Inspektor [Gadget]" ;)

> > +remoteDebuggerPromptCheck=Mich nicht mehr fragen
> 
> Ich würde "Nicht mehr nachfragen" verwenden.
Übernommen.

> ::: browser/chrome/browser/devtools/scratchpad.properties
> @@ +39,5 @@
> >  
> >  # LOCALIZATION NOTE  (scratchpadIntro): This is a multi-line comment explaining
> >  # how to use the Scratchpad. Note that this should be a valid JavaScript
> >  # comment inside /* and */.
> > +scratchpadIntro=/*\n * Dies ist eine JavaScript-Umgebung.\n *\n * Geben Sie etwas JavaScript ein und führen Sie einen Rechtsklick aus oder wählen Sie aus dem Auführen-Menu:\n * 1. Ausführen, um den ausgewählten Text zu evaluieren,\n * 2. Untersuchen, um den Objekt-Inspektor auf das Resultat anzuwenden,\n * 3. Anzeigen, um das Ergebnis in einen Kommentar hinter der Auswahl einzufügen.\n */\n\n
> 
> Ah, und da ist es ein "Inspektor". ;-)
Das Problem ist, dass "Untersuchung" in dem Fall nicht so gut passt, es sei denn, man lässt die Dopplung von "Untersuchen" in dem Satz zu.

> > +JSTerm.updateNotInspectable=Nach der Reevaluierung der Eingabe ist das Ergebnis nicht länger untersuchbar.
> 
> Das Doppel-e sieht hier komisch aus. Ist "Re-Evaluierung" besser?
Nein, ansonsten hieße es auch De-Eskalation.

> > +<!ENTITY startSafeMode.label          "Im Abgesicherten Modus starten">
> 
> Hmm, ist der als Eigenname zu betrachten? Ich würde hier Kleinschreibung
> verwenden...
Korrigiert (4x).

> > +<!ENTITY resetProfileFooter.label       "Alles Andere wird in die Ausgangseinstellungen zurückversetzt.">
> 
> "Andere" oder "andere"?
Das geht beides, ich habe "Andere" genommen, da es mehr der Logik entspricht (ohne Substantiv).

Checkin: http://hg.mozilla.org/releases/l10n/mozilla-aurora/de/rev/94316b531f38
Ich habe gerade zum ersten Mal den den Update-Button (update.restart.updateButton.label) in Aktion gesehen. Mir gefällt der Text „Zum Anwenden neu starten“ nicht besonders, da nirgendwo steht, warum was angewendet werden soll. „Zum Aktualisieren neu starten“ oder etwas in der Richtung wäre IMHO sinnvoller für „Restart to Update“.
Ich habe jetzt auf "Zum Anwenden des Updates neu starten" umgestellt. Das Problem ist ja, das vorher dort "Update wird entpackt" steht. Der Patch ist derzeit nur in Aurora, da derzeit das Übertragen der Patches bei mir nicht funktioniert (bug 778562). Was hältst Du davon?
http://hg.mozilla.org/releases/l10n/mozilla-beta/de/rev/279cbcdeec9f "Zum Anwenden des Updates neu starten"
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Attachment #640088 - Flags: review?(a.topal)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: