[RFE]History in MailNews

VERIFIED DUPLICATE of bug 74959

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED DUPLICATE of bug 74959
17 years ago
13 years ago

People

(Reporter: Lasse Marøen, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Sometimes I have missed the possibility of navigating between messages in
mailnews based on the order which they were read. It would be great to have the
opportunity of going back to read messages without having to recreate sorting
method and scrolling up and down. 

What I'd like is something like the History Sidebar, only for Mailnews. That way
one could easily find a message based on search criteria such as "I'm sure I
read this half an hour ago" or "someone said something about that in some
newsgroup I read yesterday".

Comment 1

17 years ago
So basically you want a list of say, the ten last messages you read, a little 
like the most recently accessed pages in Navigator's Go menu (but persistent 
across sessions). That's a nice idea and I don't think it would be too hard to 
implement it. Probably wouldn't make 1.0 though.
(Reporter)

Comment 2

17 years ago
Ideally I would have all the navigation features of navigator in Mailnews - Back
and forward buttons, a go menu, and the History Sidebar. I would settle for the
latter though, I guess it's a feature that wouldn't be used enough to justify a
new menu or new buttons in the mail UI. 

Updated

17 years ago
QA Contact: esther → fenella
this is a dup of a bug I logged on me.

Comment 4

17 years ago
Seth, are you thinking of bug 74959? (Implement "Back" and "Forward".)
thanks hwaara.  that's the bug I was thinking of.

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 74959 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
mark it verified/dup.
Status: RESOLVED → VERIFIED

Comment 8

17 years ago
Are you sure? Bug 74959 is for back and forward buttons in mailnews, while this
one specifically requests a history sidebar.
the other bug is the starter for adding some access keys to go back and forward.

having the history of messages show up in the history sidebar, or in some menu
is just the UI for the array of messages we'll need to keep.

please feel free to add your ideas and suggestions to the other bug, or modify
the summar to be more inclusive.

Comment 10

17 years ago
I'll post the relevant comments from this bug in bug 74959.

Comment 11

17 years ago
Okay, I've done that. I noted that some people who are on the Cc list for this
bug aren't on the Cc list for bug 74959. I was in two minds about transferring
them, and in the end, didn't. So add yourselves if you're still interested.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.