Last Comment Bug 771275 - Repeated Thunderbird+browser crashes in gfxContext::SetMatrix(gfxMatrix const&)
: Repeated Thunderbird+browser crashes in gfxContext::SetMatrix(gfxMatrix const&)
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Other Branch
: x86_64 Windows 7
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 12:38 PDT by [:jesup] on pto until 2016/7/5 Randell Jesup
Modified: 2015-10-07 18:43 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-05 12:38:13 PDT
Repeated crashes in gfxContext::SetMatrix(gfxMatrix const&), called from mozilla::layers::BasicLayerManager::PushGroupWithCachedSurface

May be a dup of bug 664764, as my crashes were for Thunderbird 13.0.1, which I'm sure doesn't have that fix (not sure when the bug went in).  They started around June 29th, which is when I updated TBird (t+12hours).  6 crashes in ~6 days.  I note a number of FF crashes with similar signatures.

All have this:
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x54

and all were called from
mozilla::layers::BasicLayerManager::PushGroupWithCachedSurface

Crash reports:
bp-9e89d719-ee0d-4a69-b273-208e62120705
bp-0604cfb3-ad23-401d-a2a5-8e6962120705
bp-b1313f56-686e-43e6-bf55-63e842120705
bp-f073660c-720e-4d0b-8169-ffafc2120705
bp-4d38577a-e75a-4355-a0bf-85b532120705
bp-45b70c12-e626-4677-8552-e96ae2120705

I saw another unconfirmed browser bug with a similar signature just filed.
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-07-05 12:39:27 PDT
Feels like this could be related to dlbi. Does it still happen on a very recent nightly?
Comment 2 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-05 12:54:06 PDT
Not dlbi, since these are crashes in release TBird (13.0.1), and appear to be new in 13 (or maybe 13.0.1 - not sure what my previous version was, but probably 12.x).

Since it crashes "randomly" in tbird while idle, regression-window would be hard to check.  Perhaps in the browser side.
Comment 3 Scoobidiver (away) 2012-07-05 23:35:40 PDT
(In reply to Randell Jesup [:jesup] from comment #0)
> May be a dup of bug 664764
This bug is fixed in branch 14.0. Does your issue happen in TB 14.0 Beta?
Comment 4 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 00:06:23 PDT
I installed beta tbird; we'll see.  If I go a week without crashing, then probably it's fixed

I normally don't run beta tbirds though
Comment 5 Wayne Mery (:wsmwk, NI for questions) 2012-08-11 07:53:28 PDT
(In reply to Randell Jesup [:jesup] from comment #4)
> I installed beta tbird; we'll see.  If I go a week without crashing, then
> probably it's fixed
> 
> I normally don't run beta tbirds though

jesup, gone for you?

essentially gone for thunderbird version 14 - crash-stats has only 3 crashes in 2 months
Comment 6 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-08-11 10:55:35 PDT
No crashes since I upgraded.  I'd close it as fixed in 14
Comment 7 Wayne Mery (:wsmwk, NI for questions) 2012-08-11 11:18:27 PDT
assumed fixed by bug 664764

Note You need to log in before you can comment on or make changes to this bug.