No security warning by clicking forward or backward

RESOLVED WORKSFORME

Status

()

Firefox
Security
P3
normal
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Diwakar Sharma, Unassigned)

Tracking

15 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20120705 Firefox/15.0a2
Build ID: 20120705042010

Steps to reproduce:

Test Case: 

  1.  Open a new tab
  2.  Navigate to about:config and click I'll be careful, I promise
  3.  In the filter box type security.warn
  4.  Double click security.warn_entering_secure and security.warn_leaving_secure if the values are FALSE
  5.  Open a new tab and navigate to http://www.google.com and click OK/Continue if a warning appears
  6.  Navigate to https://www.verisign.com and click OK/Continue if a warning appears
  7.  Click the BACK button and click OK/Continue if a warning appears

Be sure to set security.warn_leaving_secure and security.warn_entering_secure back to false by going back to the about:config tab and double clicking on it.



Actual results:

4  This step is incorrect as the values security.warn_entering_secure and security.warn_leaving_secure are already set true 
5.  After step 5 no security warning 
6.  After step 6 no security warning when you click back 
7.  After step 7 no security warning should appear when you click FORWARD

I have one more query to the developer who looks into this issue :  irrespective of we make the status of the values "security.warn_entering_secure "and "security.warn_leaving_secure" either  "TRUE" or  "FALSE" . It shows the same behavior.

so can you please double check such test cases and make sure that they are correct test cases and give clear understanding ? 


Expected results:


   1.   At step 5 , A security warning should appear when you access a secure site
   2.  After step 6 A security warning should appear when you click BACK
   3.  After step 7 A security warning should appear when you click FORWARD
(Reporter)

Updated

6 years ago
Component: Untriaged → Security
(Reporter)

Updated

6 years ago
Priority: -- → P3
(Reporter)

Comment 1

6 years ago
has anyone looked into this issue ?
This works for me under Windows 7 and Ubuntu 12.04
-the prefs are set to false by default.
-the alert is displayed when attempting to access or leave any secure site (back or forward operations)

Did you try with a clean profile?
(Reporter)

Comment 3

6 years ago
yeah its working with a clean profile can you junk this bug please
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.