Last Comment Bug 771577 - (LA-web-developer) Web Developer add-on creates zombie compartments
(LA-web-developer)
: Web Developer add-on creates zombie compartments
Status: RESOLVED FIXED
[MemShrink:P3]
:
Product: Tech Evangelism
Classification: Other
Component: Add-ons (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: addons
:
Mentors:
https://addons.mozilla.org/addon/web-...
Depends on:
Blocks: LeakyAddons ZombieCompartments
  Show dependency treegraph
 
Reported: 2012-07-06 10:20 PDT by Kris Maglione [:kmag]
Modified: 2012-08-15 07:53 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Kris Maglione [:kmag] 2012-07-06 10:20:20 PDT
I'm not entirely sure how to reproduce this. I basically selected every option the toolbar has available and then closed the tab. There are scads of them, though. I think it was something in the right third of the toolbar or so, though.

I can reproduce this in version 1.1.9 and 1.2

Developer CCd and notified via AMO.
Comment 1 Nicholas Nethercote [:njn] 2012-07-06 20:11:08 PDT
This is the 18th most popular add-on on AMO with over 1 million users, so it might be worth ranking higher than MemShrink:P3.

It'd be nice to know if it still occurs in FF15, which has bug 695480's patch.
Comment 2 Nicholas Nethercote [:njn] 2012-07-10 19:17:31 PDT
(In reply to Nicholas Nethercote [:njn] from comment #1)
> This is the 18th most popular add-on on AMO with over 1 million users, so it
> might be worth ranking higher than MemShrink:P3.

Turns out it's hard to trigger, so P3 seems ok.
Comment 3 Kris Maglione [:kmag] 2012-07-12 10:06:58 PDT
Misc > Display Ruler seems to be one way to trigger this. There seems to be some major bugginess with the Misc menu in general, though. Multiple times I wound up with ‘Display Line Guides’ checked with no way to disable it (even when I hadn't clicked it to begin with).
Comment 4 Chris Pederick 2012-07-23 23:06:33 PDT
I found and fixed the zombie compartments being created by the 'Display Ruler' feature and it will be part of the next version I submit for review. I'll update once the new version is reviewed and given the all clear.

In the meantime if anyone finds any other features that cause zombie compartments please update this ticket as I have not discovered any yet.
Comment 5 Kris Maglione [:kmag] 2012-08-15 07:53:07 PDT
Seems fixed in version 1.2.1. The bugginess mentioned in comment 3 remains.

Note You need to log in before you can comment on or make changes to this bug.