[meta] Clearing recent history for a time period incorrectly clears any Site Preferences set before the time period

RESOLVED FIXED

Status

()

Firefox
Preferences
--
enhancement
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

({dataloss, meta})

13 Branch
dataloss, meta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Selected tools->Clear Recent History->Last Hour


Actual results:

In addition to clearing recent history, it removed all zooming (e.g. from when I pressed ctrl and + buttons) on all sites even though I had pressed ctl+ a week earlier.


Expected results:

The zooming settings should have remained.

Updated

6 years ago
Component: Untriaged → Preferences
(Reporter)

Comment 1

5 years ago
This still occurs in FF20.

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → bug 380852

Updated

4 years ago
Duplicate of this bug: 981094

Comment 3

4 years ago
FYI:
https://hg.mozilla.org/mozilla-central/annotate/7a2edc5171e6/browser/base/content/sanitize.js#l104
siteSettings: {  not include  if (this.range) {
Flags: needinfo?(johnath)
Flags: needinfo?(johnath)

Updated

4 years ago
Flags: firefox-backlog+
(Reporter)

Comment 4

4 years ago
(In reply to YF (Yang) from comment #3)
> FYI:
> https://hg.mozilla.org/mozilla-central/annotate/7a2edc5171e6/browser/base/
> content/sanitize.js#l104
> siteSettings: {  not include  if (this.range) {

I see your comment, but I don't see that code anywhere. I just see it defaulting to still clearing everything.

Comment 5

4 years ago
To donrhummy:
That was my reference to johnath (the code's developer), but he does not seem interested.

Comment 6

4 years ago
I suddenly understood, zoom preferences's structure may not contain a timestamp, so impossible to clear specified time range, have to clear all.

https://developer.mozilla.org/en-US/docs/XPCOM_Interface_Reference/nsIContentPrefService2

so, to enhancement?
Severity: normal → enhancement

Updated

4 years ago
Summary: Clearing last hour of history incorrectly clears any zoom settings even if they were set a week ago → Breakdown - Clearing last hour of history incorrectly clears any zoom settings even if they were set a week ago

Updated

4 years ago
Whiteboard: p=1
Points: --- → 1
Keywords: dataloss
OS: Linux → All
Hardware: x86_64 → All
Summary: Breakdown - Clearing last hour of history incorrectly clears any zoom settings even if they were set a week ago → Breakdown - Clearing recent history for a time period incorrectly clears any Site Preferences even if they were set a week ago
Whiteboard: p=1
Summary: Breakdown - Clearing recent history for a time period incorrectly clears any Site Preferences even if they were set a week ago → Breakdown - Clearing recent history for a time period incorrectly clears any Site Preferences set before the time period
Note that this affects both the Permission Manager, Content Pref Service, & Password Manager Exceptions (which should probably switch to using the Permission Manager).

We could add a new modification time column to the two stored and set its value to the current time when a permission or content pref changes. When sanitize.js is used just remove permissions that have a modification time in the time window specified. I realize this isn't perfect because it won't revert the permission to a previous non-default value from before the time period chosen but I think it's "good enough" and better than the current situation of deleting all permissions/preferences.

Updated

4 years ago
QA Whiteboard: [qa-]

Updated

4 years ago
QA Whiteboard: [qa-]
Flags: qe-verify-

Updated

4 years ago
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Iteration: --- → 34.3
Given this was opened by a user reporting a real bug, it doesn't seem correct to have it morphed into a "breakdown" and thus marked as fixed when the breakdown is complete rather than the issue being addressed.

I opened bug 1058430 to be the actual breakdown, and I'll mark the relevant sub-bugs as blocking this one.  Marco, please update the current iteration spreadsheet accordingly.
Assignee: mhammond → nobody
Iteration: 34.3 → ---
Points: 1 → ---
Flags: qe-verify- → qe-verify+
Summary: Breakdown - Clearing recent history for a time period incorrectly clears any Site Preferences set before the time period → Clearing recent history for a time period incorrectly clears any Site Preferences set before the time period

Updated

4 years ago
Depends on: 1058433

Updated

4 years ago
Depends on: 1058435

Updated

4 years ago
Depends on: 1058438

Updated

4 years ago
Depends on: 1058442
Thanks for the update Mark.  I've made the update to reflect your changes.

(In reply to Mark Hammond [:markh] from comment #8)
> Given this was opened by a user reporting a real bug, it doesn't seem
> correct to have it morphed into a "breakdown" and thus marked as fixed when
> the breakdown is complete rather than the issue being addressed.
> 
> I opened bug 1058430 to be the actual breakdown, and I'll mark the relevant
> sub-bugs as blocking this one.  Marco, please update the current iteration
> spreadsheet accordingly.
Status: ASSIGNED → NEW

Comment 10

4 years ago
Per email discussion, seems like this should be a meta bug.
Flags: firefox-backlog+
Keywords: meta
Summary: Clearing recent history for a time period incorrectly clears any Site Preferences set before the time period → [meta] Clearing recent history for a time period incorrectly clears any Site Preferences set before the time period
Thanks for catching that Gijs.

(In reply to :Gijs Kruitbosch from comment #10)
> Per email discussion, seems like this should be a meta bug.
Flags: qe-verify+

Updated

4 years ago
No longer blocks: 1050080
Duplicate of this bug: 608588
All the dependencies are now fixed! The Site Settings option respects the time period.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.