can't add text to filter rule boxes unless resize the message filter dialog box

RESOLVED DUPLICATE of bug 736635

Status

MailNews Core
Filters
RESOLVED DUPLICATE of bug 736635
6 years ago
2 years ago

People

(Reporter: webmaster2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 639783 [details]
screenshot of message filter dialog, size that causes bug

I attempted to create a new message filter.  I added text to the first rule box, and when I clicked "+" the text disappeared.  Clicking "+" did not create a new rule line.  I was able to get around the bug by making the message filter dialog box bigger (dragging lower right corner).  I am able to reproduce the problem by making the dialog box smaller again (see attached screen shot).  I have 42 message filters defined, about 2/3 of which are active and the rest are disabled.

Mac OS X Lion 10.7.3

thanks,
JC
(Reporter)

Updated

6 years ago
Version: unspecified → 13
Component: General → Filters
Product: Thunderbird → MailNews Core

Comment 1

6 years ago
Is the scrollbar appearing properly?
If the dialog is that small, any new rule created immediatelly shifts the previous rule out of sight behind the top edge of the rules list. This transition looks like the text has disappeared because all the other fields are the same and it looks like you are still in the same rule. But you should be able scroll back to it.

Or is there any other problem?

Maybe we should disallow the dialog to become so small? Force a minimum height to show at least 2-3 rules ?

Comment 2

6 years ago
This may be related to bug 736635, where the initial dialog size is set too small on OS X.
See Also: → bug 736635
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Depends on: 736635
Resolution: --- → DUPLICATE
Duplicate of bug: 736635
You need to log in before you can comment on or make changes to this bug.