Open Bug 771767 Opened 12 years ago Updated 1 year ago

Buttons in 'Untrusted Connection' tab are unresponsive after tab dragging

Categories

(Firefox :: General, defect)

x86
All
defect

Tracking

()

People

(Reporter: dominic.skw, Unassigned)

References

Details

(Keywords: regression)

Replication steps:
1) Ensure that Firefox is not running, and open a new instance of Firefox.
2) Navigate to a either a non-https website (for example, http://www.mozilla.org/en-US/) or a https site with a valid SSL certificate (for example, https://www.google.com).
3) Open a new tab by pressing Ctrl-T, and then navigate to a website with an invalid SSL certificate, for example, https://tv.eurosport.com/. You should observe a tab with the 'Untrusted Connection' title being displayed.
4) Perform tab dragging by clickinf-and-holding the 'Untrusted Connection' tab, and then release the tab when the mouse pointer is below the URL bar. You should observe that a new Firefox window displaying the 'Untrusted Connection' tab was created.
5) Click on the 'Get me out of here!' button. You should observe that there is no response from the browser.
5a) Expected outcome: the browser should redirect the user away from the current page.

In some cases, the 'Add Exception...' button will also be unresponsive after replicating the above steps. The user may click on the 'Technical Details' division, and then click on 'Get me out of here!' button. The browser will then redirect the user accordingly.
Confirmed in
http://hg.mozilla.org/mozilla-central/rev/a8f682801a6d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120706075126

Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/e75e9d539c40
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre ID:20100819180028
Bad:
http://hg.mozilla.org/mozilla-central/rev/80b450a23c6b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre ID:20100819201833
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e75e9d539c40&tochange=80b450a23c6b
Status: UNCONFIRMED → NEW
Component: Tabbed Browser → DOM: Core & HTML
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
Version: 13 Branch → Trunk
Keywords: regression
In local build(ubuntu 32bit)
Last Good: 1493938c90c8
First Bad: 61fd19a4587f

Triggered by:	
61fd19a4587f	Jonas Sicking — Bug 546857 Part 3: Make error pages not use xul buttons. r=dao a=blocker
Component: DOM: Core & HTML → XUL
Doesn't seem related to XUL...  Either a bug in the error page or in the browser UI.
Component: XUL → Document Navigation
Component: Document Navigation → Tabbed Browser
Product: Core → Firefox
Component: Tabbed Browser → General
In a related issue, if you perform steps 1-4 in the original bug report, and then click on "I understand the Risks" (this works) and then "Add Exeption" button (this doesn't), nothing happens.  Refreshing the page both via right-click/Reload and CTRL-R do resolve the problem for this untrusted connection.
I've only seen this on a vcenter 5.50b web interface (it may be the first such page I've tried to move prio to clicking 'Add Exception.'
This is in Firefox version 29.0 running on Windows 7 x64 Pro.
A little update: on the current Nightly build, I can’t drag out the tab with Untrusted Connection warning, but clicking on the “Get me out of here” button worked.

What’s the progress on this bug?
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.