startup crash in mozilla::AndroidBridge::IsTablet

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
6 years ago
18 days ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash})

Trunk
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [startupcrash][native-crash], crash signature)

(Reporter)

Description

6 years ago
There are 2 crashes in 14.0 Beta and one in 16.0a1/20120707.

Signature 	_JNIEnv::CallStaticBooleanMethod | mozilla::AndroidBridge::IsTablet More Reports Search
UUID	e5d00452-dc44-4029-b908-71e3a2120707
Date Processed	2012-07-07 16:37:47
Uptime	0
Install Age	0 seconds since version was first installed.
Install Time	2012-07-07 16:37:33
Product	FennecAndroid
Version	16.0a1
Build ID	20120707030542
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 3.0.15-N7000JPLPD-CL643396 #3 SMP PREEMPT Thu May 31 16:09:57 KST 2012 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0x2740fc
App Notes 	
samsung GT-N7000
samsung/GT-N7000/GT-N7000:4.0.3/IML74K/JPLPD:user/release-keys
Processor Notes 	WARNING: JSON file missing Add-ons
EMCheckCompatibility	False

Frame 	Module 	Signature 	Source
0 	libdvm.so 	libdvm.so@0x2074c 	
1 	libdvm.so 	libdvm.so@0xb3f9a 	
2 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2abc6e 	
3 	libdvm.so 	libdvm.so@0x343f2 	
4 	framework.odex 	framework.odex@0x394b56 	
5 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2ac98e 	
6 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2abc6e 	
7 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x12fa74 	
8 	libdvm.so 	libdvm.so@0x6ccdf 	
9 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2abc6e 	
10 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2abc6e 	
11 	libdvm.so 	libdvm.so@0x553e1 	
12 	libdvm.so 	libdvm.so@0x5553f 	
13 	libdvm.so 	libdvm.so@0x553bf 	
14 	libxul.so 	_JNIEnv::CallStaticBooleanMethod 	jni.h:765
15 	libxul.so 	mozilla::AndroidBridge::IsTablet 	widget/android/AndroidBridge.cpp:2044
16 	libxul.so 	ParseManifest 	xpcom/components/ManifestParser.cpp:475
17 	libxul.so 	nsComponentManagerImpl::RegisterManifest 	xpcom/components/nsComponentManager.cpp:497
18 	libxul.so 	nsComponentManagerImpl::RereadChromeManifests 	xpcom/components/nsComponentManager.cpp:665
19 	libxul.so 	nsComponentManagerImpl::Init 	xpcom/components/nsComponentManager.cpp:365
20 	libxul.so 	NS_InitXPCOM2_P 	xpcom/build/nsXPComInit.cpp:468
21 	libxul.so 	ScopedXPCOMStartup::Initialize 	toolkit/xre/nsAppRunner.cpp:1166
22 	libxul.so 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3859
23 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3940
24 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:73
...

More reports at:
https://crash-stats.mozilla.com/query/query?product=FennecAndroid&range_value=4&range_unit=weeks&query_search=signature&query_type=contains&query=mozilla%3A%3AAndroidBridge%3A%3AIsTablet&do_query=1
(Reporter)

Updated

6 years ago
Duplicate of this bug: 746085
(Reporter)

Updated

6 years ago
Crash Signature: [@ dvmJitGetCodeAddr | dvmAsmSisterStart | dvmMterpStd | dvmInterpret | dvmCallMethodV | JNI_CreateJavaVM | _JNIEnv::CallStaticBooleanMethod | mozilla::AndroidBridge::IsTablet] [@ _JNIEnv::CallStaticBooleanMethod | mozilla::AndroidBridge::IsTablet ] → [@ dvmJitGetCodeAddr | dvmAsmSisterStart | dvmMterpStd | dvmInterpret | dvmCallMethodV | JNI_CreateJavaVM | _JNIEnv::CallStaticBooleanMethod | mozilla::AndroidBridge::IsTablet] [@ _JNIEnv::CallStaticBooleanMethod | mozilla::AndroidBridge::IsTablet] [@ _…
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 18 days ago
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
You need to log in before you can comment on or make changes to this bug.