Kuma: Broken links in "Recent Docs Activity" due to locale

VERIFIED FIXED

Status

Mozilla Developer Network
Localization
P1
normal
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: fscholz, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Visit my *German* profile page and jump to "Recent Docs Activity":
https://developer-new.mozilla.org/de/profiles/Elchi3

We got some action links there:
Edit page | View complete diff | View page history

However, they link to the locale you are currently viewing the profile (which is German here). The following link 404's as a consequence:
https://developer-new.mozilla.org/de/docs/XBL/XBL_1.0_Reference/Elements$edit
It should be:
https://developer-new.mozilla.org/en-US/docs/XBL/XBL_1.0_Reference/Elements$edit

So the action links should have the locale of the edited document instead of the locale with which I visit the profile. (If I visit https://developer-new.mozilla.org/fr/profiles/Elchi3 everything gets french, and so do the URLs of the action links)

Comment 1

6 years ago
high priority post-launch
Priority: -- → P2
(Reporter)

Updated

5 years ago
Component: Docs Platform → Localization
Duplicate of this bug: 780190
Priority: P2 → P1

Comment 3

5 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/a99ee72879d55824a4d329c4c5f4628885c67d33
Fix bug 771820 - Profile: Correct URLs in Recent Docs Activity

https://github.com/mozilla/kuma/commit/497af077317ec1d72b7d76cefb73c51e134c2608
Merge pull request #557 from Elchi3/771820-profile-links

Fix bug 771820 - Profile: Correct URLs in Recent Docs Activity

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified
You need to log in before you can comment on or make changes to this bug.