Test fails during test-tab-browser.testTabModuleActiveTab_getterAndSetter (timed out) on Windows debug builds

RESOLVED DUPLICATE of bug 758283

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 758283
6 years ago
6 years ago

People

(Reporter: ochameau, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Here is the trace:
info: pass: Correct active tab on window 1
info: pass: Correct active tab on window 2
error: An exception occurred.
Traceback (most recent call last):
  File "resource://d1cbf110-4491-498a-b23d-481c59d4601a-at-jetpack/api-utils/lib/timer.js", line 28, in notify
    callback.apply(null, args);
  File "resource://d1cbf110-4491-498a-b23d-481c59d4601a-at-jetpack/api-utils/lib/tab-browser.js", line 542, in 
    require("./errors").catchAndLog(function(tab) options.onOpen(tab))(tab);
  File "resource://d1cbf110-4491-498a-b23d-481c59d4601a-at-jetpack/api-utils/lib/errors.js", line 19, in 
    return callback.apply(this, arguments);
  File "resource://d1cbf110-4491-498a-b23d-481c59d4601a-at-jetpack/api-utils/lib/tab-browser.js", line 542, in 
    require("./errors").catchAndLog(function(tab) options.onOpen(tab))(tab);
  File "resource://d1cbf110-4491-498a-b23d-481c59d4601a-at-jetpack/api-utils/tests/test-tab-browser.js", line 358, in 
    tm1.activeTab = tab1;
  File "resource://d1cbf110-4491-498a-b23d-481c59d4601a-at-jetpack/api-utils/lib/tab-browser.js", line 366, in 
    let [tabElement, win] = getElementAndWindowForTab(tab, window);
  File "resource://d1cbf110-4491-498a-b23d-481c59d4601a-at-jetpack/api-utils/lib/tab-browser.js", line 555, in getElementAndWindowForTab
    let index = win.gBrowser.getBrowserIndexForDocument(tabObj.contentDocument);
TypeError: tabObj is null

Might be some race condition to debug build slowness...
Some other tests are failing after this one, but they most likely fail because of this one not being cleaned up.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 758283
You need to log in before you can comment on or make changes to this bug.