Updates do not differentiate between different installs of same application and branch

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: aryx, Unassigned)

Tracking

15 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 640071 [details]
update history

TL;DR Updating my English Firefox Aurora build with German language pack installed returned an Aurora build which is native German (stays German after uninstalling the language pack).

Long version:
I installed a German language pack (created by myself) for Firefox Aurora into the 20120706 Windows 32 bit build on Windows XP SP 3 and checked for updates. After the update, some strings were in English, so I searched for the reason and found Aurora ignoring the language pack because itself was now in German.

I have both German and English Aurora builds installed with different profiles. The German one has been installed by unzipping it, the English one by running the .exe file. The German one shows Aurora's translation state into German, the English one is used for testing (e.g. for the German localization).

The update history (Preferences > Advanced > Update > Update history) shows the update history of both builds, 07 is the latest German build, 08 the latest English one (I fixed the issue by installing an older English build when I tried to reproduce the issue.)
Sorry I don't see why this is related to the MozillaMaintenance service? The MozillaMaintenance service just allows us to get past the UAC screen.  Could you rename the title or explain why you think this is related to the service?
I don't know if it is the reason, it is only the first suspect as it landed recently and updating with language packs and the second install worked without issues in the past. Is MMS able to manage more than one pending update for the same branch? If you think the bug belongs elsewhere, feel free to move it. Thank you.
I don't fully understand the issue but I'm pretty sure it is unrelated to the MozillaMaintenance Service.  I'll move this over to toolkit/application update.
Component: Installer → Application Update
Product: Firefox → Toolkit
Summary: MozillaMaintenance service doesn't differentiate between different installs of same application and branch → Updates do not differentiate between different installs of same application and branch
I'd be interested to know what happens if you take an en-US Aurora again, put in your homemade langpack, and then grab the update url from the Error Console. You'd need to set app.update.log to true and restart the Aurora first.
This returns the url as expected with en-US: AUS:SVC Checker:checkForUpdates - sending request to: https://aus3.mozilla.org/update/3/Firefox/15.0a2/20120713042008/WINNT_x86-msvc/en-US/aurora/Windows_NT%205.1.3.0%20(x86)/default/default/update.xml?force=1
The update log in the screenshot seems to show the updates for both application directories, so does the update share something?
OK, so it's querying properly. Is the conversion to a de build reproducible ?
I was unable to reproduce with the 20120913 Aurora builds, updating worked. Starting an update download in one build and quitting this one and starting the other one and checking for updates resumes the download from the first one, but it seems there is a download verification after the download has finished which lets the update fail.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
which program does the download verification?
Firefox Aurora in the "About Aurora" window, the text is something like "Update failed. Download the manual installer yada yada".
You need to log in before you can comment on or make changes to this bug.