Closed Bug 771920 Opened 9 years ago Closed 9 years ago

Debug builds unusable on mac due to write poisoning

Categories

(Core :: XPCOM, defect)

x86
macOS
defect
Not set
blocker

Tracking

()

RESOLVED DUPLICATE of bug 771083

People

(Reporter: bzbarsky, Unassigned)

References

Details

I had a debug build crash.  Now every time I start it, the following things happen:

1)  WARNING: Last startup was detected as a crash.: 
    file ../../../../mozilla/toolkit/components/startup/nsAppStartup.cpp,
    line 942
2)  ###!!! ASSERTION: consider quit stopper out of bounds:
    'mConsiderQuitStopper > 0', file 
    ../../../../mozilla/toolkit/components/startup/nsAppStartup.cpp, line 533
3)  Process shuts down (why?  who knows)
4)  WARNING: XPCOM objects created/destroyed from static ctor/dtor:
    file ../../../mozilla/xpcom/base/nsTraceRefcntImpl.cpp, line 141 several
    times
5)  Assertion failure: r == count, at
    ../../../mozilla/xpcom/build/mozPoisonWriteMac.cpp:194

#5 of course crashes the process, so the next time around the same exact things happens.  Result: I can't start the build at all.

I _think_ steps 1-4 were preexisting, but step 5 was added in bug 732173 and makes it completely impossible to use the build.

The stack to #5 is:

#0  AbortOnBadWrite (fd=4, wbuf=0x1003a91e0, count=5) at mozPoisonWriteMac.cpp:194
#1  0x0000000103e9d2c3 in wrap_write_temp (fd=4, buf=0x1003a91e0, count=5) at mozPoisonWriteMac.cpp:38
#2  0x0000000103e9d293 in wrap_write (fd=4, buf=0x1003a91e0, count=5) at mozPoisonWriteMac.cpp:85
#3  0x00000001000b7b14 in pt_Write (fd=0x119f33d60, buf=0x1003a91e0, amount=5) at ptio.c:1315
#4  0x00000001000870e6 in PR_Write (fd=0x119f33d60, buf=0x1003a91e0, amount=5) at priometh.c:114
#5  0x0000000100092163 in PR_vfprintf (fd=0x119f33d60, fmt=0x104be61e8 "%d\n", ap=0x7fff5fbfea60) at prstdio.c:70
#6  0x00000001000920bc in PR_fprintf (fd=0x119f33d60, fmt=0x104be61e8 "%d\n") at prstdio.c:19
#7  0x00000001036ae01c in RecordShutdownEndTimeStamp () at nsAppStartup.cpp:308
#8  0x00000001036ae9b1 in RecordShutdownEndTimeStampHelper::~RecordShutdownEndTimeStampHelper (this=0x105be5ce0) at nsAppStartup.cpp:323
#9  0x00000001036ae1d5 in RecordShutdownEndTimeStampHelper::~RecordShutdownEndTimeStampHelper (this=0x105be5ce0) at nsAppStartup.cpp:322
#10 0x00007fff8831e374 in __cxa_finalize ()
#11 0x00007fff8831e28c in exit ()
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 771083
You need to log in before you can comment on or make changes to this bug.