Kuma: Caching is clearly broken somehow

RESOLVED FIXED

Status

developer.mozilla.org
Wiki pages
P1
blocker
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
When I make a change to a page and save, several pages in a row (including changes to templates), doing normal workflow, maybe working on several saves to the same page, etc, eventually I get to a point where each load of the same page gives me different output, sometimes mixing results from different old versions of templates in different calls to the template on the same page load.

As a result, the output I get from a given page flow can vary wildly from one reload to the next, even if I change nothing in between.

Something is very very wrong with that; it's highly disruptive to work flow and makes it essentially impossible to test template and other content changes when there's no way to know if what you're seeing matches the save you just made. This must be fixed ASAP.
I can't really reproduce this and don't have much info to go on... Can you say what pages & templates you were editing?

Also, have you tried hitting shift-refresh on any pages that seemed problematic? 

https://developer.mozilla.org/Project:en/Introduction_to_KumaScript#Caching
Summarizing from some discussion in IRC: we're currently running on locmem caching, which is isolated per-process. Since apache is running multiple processes, they each have a separate cache. So, hitting different processes will yield different cache sets. That could explain the above

One suggested fix is to switch to DB caching, since memcache is presenting issues: https://docs.djangoproject.com/en/1.2/topics/cache/#database-caching
I think we just fixed this with DB caching.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Version: Kuma → unspecified
(Assignee)

Updated

6 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.