Closed Bug 772167 Opened 8 years ago Closed 2 years ago

IndexedDB failures seen while running Gallery app in b2g desktop

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dhylands, Unassigned)

Details

(Whiteboard: b2g-desktop-builds)

Attachments

(1 file)

I was running b2g desktop under linux. My ~/Pictures directory has about 5500 photographs in it.

The first problems seem to start around line 276 of the output.
I think this probably just needs bug 759427.
Depends on: 759427
So Gallery wasn't being run OOP at the time.

Using a directory containing much fewer photos worked fine.
Oops, missed that important detail. Ok, sounds like jan might need to have a look?
No longer depends on: 759427
It fails in DoPendingOpen() in FileStreams.cpp, invoked by the Seek() method
GetInternalStream() usually doesn't need to open the file, but it seems it's a blob slice that is being stored in IDB in this case.

The nsPartialFileInputStream shouldn't call Seek() in the Init() method, it causes main thread IO, but that's a different bug

I don't know why it fails to open the file, maybe it doesn't exist or a problem with permissions ?
Please file that MT I/O, its probably part of the perf problems I am seeing.
I know about some "SQLite returned error code 1" being caused by offline cache initialization.  We are altering some tables every time on startup.  That of course leads to a warning-like errors.

Others need more investigation.
dhylands: with what version (changeset) did you create the log?  Just to be sure on line numbers.
(In reply to Andreas Gal :gal from comment #5)
> Please file that MT I/O, its probably part of the perf problems I am seeing.

bug 772528
My gaia tree is currently sitting at 45531e9e33608fdc0ca9766790546e94e5379e8f
My src tree (m-c) is from git, and is sitting at 2491fb74f90d7e7437f0f0af232122bc5c6d72da
using whiteboard "b2g-desktop-builds" for ease of tracking
Whiteboard: b2g-desktop-builds
Does this bug influences any functionality or is just about logs in the console?  (Prioritizing)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.