Last Comment Bug 772246 - nsSVGUtils::GetPostFilterVisualOverflowRect should not offset the returned rect
: nsSVGUtils::GetPostFilterVisualOverflowRect should not offset the returned rect
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on:
Blocks: 614732
  Show dependency treegraph
 
Reported: 2012-07-09 14:56 PDT by Jonathan Watt [:jwatt]
Modified: 2012-07-10 15:46 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1019 bytes, patch)
2012-07-10 01:23 PDT, Jonathan Watt [:jwatt]
roc: review+
Details | Diff | Review

Description Jonathan Watt [:jwatt] 2012-07-09 14:56:31 PDT
nsSVGUtils::GetPostFilterVisualOverflowRect should not offset the returned rect by the GetPosition() of the frame, since the overflow rects are supposed to be relative to the top-left of the frame's mRect.
Comment 1 Jonathan Watt [:jwatt] 2012-07-10 01:23:21 PDT
Created attachment 640532 [details] [diff] [review]
patch
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-07-10 15:46:46 PDT
https://hg.mozilla.org/mozilla-central/rev/512948e12f25

Note You need to log in before you can comment on or make changes to this bug.