NumLock OFF intermittently ignored by TB (and FF): numeric keypad sometimes does numbers instead of navigation, and toggling NumLock has no effect

UNCONFIRMED
Unassigned

Status

P3
normal
UNCONFIRMED
6 years ago
a year ago

People

(Reporter: david.cullen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AV:Webroot SecureAnywhere])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

 1. Ctrl+N or [Message]->[New Message]
 2. Enter e-mail addresses
 3. Enter subject
 4. Type a few lines in the body
 5. Use the numeric keypad to move around the body



Actual results:

Numbers are entered into the body of the composition window.


Expected results:

The numeric keypad keys should allow the user to move up, down, left, right, page up, page down, move to the beginning of a line, and move to the end of a line.
(Reporter)

Comment 1

6 years ago
This problem seems to be intermittent.  I just tried to duplicate the problem when creating a new message and when replying to an existing message, but I could not reproduce it.
David, are you aware of the following?

There's a key called "NumLock" to enable or disable the numeric keypad.
- with "NumLock" ON, numeric keypad will type numbers
- with "NumLock" OFF, numeric keypad will provide navigational keys
This is expected behaviour, and we can't and won't change that.

This worksforme on WinXP/TB13, and I think it's very unlikely things are different on Win7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

6 years ago
The problem does not follow the setting of the NumLock key.

I have my system setup to disable NumLock at boot, as I have done for the past 20 years.

At first I thought that some rogue application was messing with the NumLock setting.  It turns out that for all other applications (except Firefox and Thunderbird), the NumLock setting is handled correctly.

So the rogue applications are Thunderbird and Firefox.  I filed the bug for Thunderbird because that's where I noticed it first.  However, I am seeing the same problem when filling out forms with Firefox 13.0.1.  I can duplicate the problem in this text field:  8882227144466693.

That was
    Up arrow 3 times
    Down arrow 3 times
    Home
    End
    Left arrow 3 times
    Right arrow 3 times
    PgUp
    PgDn

I just opened an e-mail composition Window in Thunderbird 13.0.1 and now I can duplicate the problem.

So the problem may be caused by some bad code that is shared between Thunderbird and Firefox, but triggered when filling out a form in Firefox.

I submitted a bug for Firefox:  https://bugzilla.mozilla.org/show_bug.cgi?id=772852
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
David, so you are saying that the *LED* for NumLock is *OFF* (no light), but using the numeric keypad still produces number characters (but only in TB and FF)?

This wfm here in bmo: After switching off NumLock key (LED off), typing 8 and 2 on numeric keypad moves my cursor up/down within the comment (on winXP 32bit; reported against win7 64bit).

David, can you post the code which disables your NumLock at boot?
Is it *disabled* or just *switched off*?
(Reporter)

Comment 5

6 years ago
> David, so you are saying that the *LED* for NumLock is *OFF*
> (no light), but using the numeric keypad still produces number
> characters (but only in TB and FF)?

Yes

> This wfm here in bmo: After switching off NumLock key (LED off),
> typing 8 and 2 on numeric keypad moves my cursor up/down within
> the comment (on winXP 32bit; reported against win7 64bit).

Please explain "bmo".

I'm glad it works for you.  I just tested it again in Firefox and Thunderbird and I get intermittent results. Sometimes I have the problem and sometimes I don't. But I only have the problem in Firefox and Thunderbird.

> David, can you post the code which disables your NumLock at boot?
> Is it *disabled* or just *switched off*?

Please explain "post the code".

I believe it is disabled because when I use _any_ other program, the program behaves as if NumLock is disabled.

However, most of the time when I use Thunderbird or Firefox, they behave as if NumLock is enabled.

Unfortunately, the problem is intermittent and hard to reproduce. This is how intermittent the problem is. I clicked on the link for the bug report and started using the numeric keypad to navigate in the text box on the form and I typed something like this: 88884444. Then I opened a couple of other windows to get a text editor that didn't suffer from the problem so I could compose this reply. When I switched back to Firefox, the problem no longer manifested itself. So, the problem is with Firefox and Thunderbird, but I cannot always duplicate it.
(In reply to David Cullen from comment #5)
> > David, so you are saying that the *LED* for NumLock is *OFF*
> > (no light), but using the numeric keypad still produces number
> > characters (but only in TB and FF)?
> 
> Yes
> 
> > This wfm here in bmo: 
> 
> Please explain "bmo".

bugzilla.mozilla.org

> I'm glad it works for you.  I just tested it again in Firefox and
> Thunderbird and I get intermittent results. Sometimes I have the problem and
> sometimes I don't. But I only have the problem in Firefox and Thunderbird.

That's amazing, especially the intermittent bit...

> > David, can you post the code which disables your NumLock at boot?
> > Is it *disabled* or just *switched off*?
> 
> Please explain "post the code".

I thought maybe you are using some kind of batch script to switch of NumLock, because you said "I have my system setup to disable NumLock at boot"
How do you "disable" NumLock at boot?

> I believe it is disabled because when I use _any_ other program, the program
> behaves as if NumLock is disabled.

We can agree that the behaviour of NumLock should be consistent regardless of the program used...
There might be a difference between completely "disabling" NumLock (so that even when you press the NumLock key, it will not change status), and just "switching off" (changing the status of NumLock). I assume you are not disabling, but just toggling NumLock to false (off).

> However, most of the time when I use Thunderbird or Firefox, they behave as
> if NumLock is enabled.

I find it hard to believe that NumLock status LED on keyboard is off but still behaves like it was on in TB and FF only, but well, strange things can happen...
 
> Unfortunately, the problem is intermittent and hard to reproduce. This is
> how intermittent the problem is. I clicked on the link for the bug report
> and started using the numeric keypad to navigate in the text box on the form
> and I typed something like this: 88884444. Then I opened a couple of other
> windows to get a text editor that didn't suffer from the problem so I could
> compose this reply. When I switched back to Firefox, the problem no longer
> manifested itself.

That's even more amazing...

> So, the problem is with Firefox and Thunderbird, but I
> cannot always duplicate it.

I have some doubts that this is a FF/TB problem...

Are you using any other programs that might affect the on/off status of NumLock?
Perhaps your physical NumLock key on the keyboard is faulty?
What happens if you press NumLock key on keyboard: does it react as expected?
...and when you get the unexpected/"wrong" behaviour (numbers) in TB/FF, and then press the NumLock key once, does it return to "correct" behaviour (navigation)?
(Reporter)

Comment 8

6 years ago
88882222

The above was typed in Firefox after clicking the link to this bug.  I used the numeric keypad with the NumLock LED off.

> I thought maybe you are using some kind of batch script to switch off
> NumLock, because you said "I have my system setup to disable NumLock
> at boot"
> How do you "disable" NumLock at boot?

I turn off "NumLock on at boot" in BIOS. I have done this with every PC I have ever owned since I got my first IBM clone in 1986. It is a ubiquitous setting. If you look in your BIOS settings, you should have the equivalent.  If you don't I will be the one who is amazed.

> There might be a difference between completely "disabling" NumLock
> (so that even when you press the NumLock key, it will not change
> status), and just "switching off" (changing the status of NumLock).
> I assume you are not disabling, but just toggling NumLock to false (off).

By default, PCs usually ship with "NumLock on at boot".  However, enough people desire the opposite behavior that there is always a BIOS setting to to turn it off.

> I find it hard to believe that NumLock status LED on keyboard is off but
> still behaves like it was on in TB and FF only, but well, strange things
> can happen...

    "And straightway the father of the child cried out, and said with tears, Lord, I believe; help thou mine unbelief."

Believe it.  Please.  My other option is that you don't believe me, and I have to switch to some lesser program, probably something ncurses based.

> I have some doubts that this is a FF/TB problem...

If it helps you track down the cause of the problem, I think I first noticed this behavior back in Thunderbird 11.  I waited a long time to report the bug because it was intermittent, and I wasn't certain it was isolated to Thunderbird.  However, I have been composing more e-mails than usual lately, and the problem has happened so frequently that I was finally convinced that it was a problem with Thunderbird.  Ironically, when I started the process of reporting the defect, I noticed that Firefox had the same problem.

> Are you using any other programs that might affect the on/off status
> of NumLock?

I run Oracle VirtualBox, which might have the ability to toggle NumLock.  But I am using it to run Ubuntu Server 12.04 without any window manager and I SSH into it using PuTTY, so I am doubtful that it is messing with the NumLock setting.

> Perhaps your physical NumLock key on the keyboard is faulty?

It seems to work fine in every other program.

> What happens if you press NumLock key on keyboard: does it react as
> expected?

Yes.

If the NumLock LED is off and I press the NumLock key, the LED turns on and the numeric keypad types numbers in other programs.

If the NumLock LED is on and I press the NumLock key, the LED turns off and the numeric keypad types navigation keys in other programs.

> ...and when you get the unexpected/"wrong" behaviour (numbers) in
> TB/FF, and then press the NumLock key once, does it return to
> "correct" behaviour (navigation)?

No.  When the problem manifests itself, Thunderbird and Firefox ignore the state of the NumLock key.

Just to help you out, whenever the problem occurred, I tried everything I could think of to make sure it was specific to Thunderbird.  I switched to another program and verified that the numeric keypad was in the "NumLock off" state consistent with the LED.  I then toggled to the "NumLock on" state and verified that I was able to enter numbers in the other program.  Then I switched back to Thunderbird and typed some numbers.  Then I toggled to the "NumLock off" state and verified that the numeric keypad still typed numbers.

Contrary to what you normally have to deal with, I wouldn't report a bug like this unless I was fully convinced that the problem was only with Thunderbird and Firefox.  As I said, I waited several months to report the problem.

All that being said, the numeric keypad is now function correctly as navigation keys in this text box.  And I just clicked reply to an e-mail in Thunderbird and I was able to use the numeric keypad to navigate in the composition window.  So the problem is still intermittent.

The only constant is that when it happens, it happens in Thunderbird and Firefox.
Thank you David for quick & comprehensive reply which helps to clarify your issue.
Comment 8 adds valuable information for understanding this problem.

I believe what you are saying, but I was just trying to exclude distractors/misunderstandings, and to gather as many reliable details of the reported behaviour as possible so that others will have solid information for further analysis.

I'm a volunteer contributor myself. Beyond improving the quality of this bug report, I'm afraid I can't do much more for you in this case, because I can't reproduce the problem (under different OS than reporter).
Summary: Numeric keypad does not work properly in Thunderbird 13.0.1 for Windows 7 → NumLock OFF (to use numeric keypad for navigation) intermittently ignored by TB (and FF): does numbers instead of navigation
Summary: NumLock OFF (to use numeric keypad for navigation) intermittently ignored by TB (and FF): does numbers instead of navigation → NumLock OFF (to use numeric keypad for navigation) intermittently ignored by TB (and FF): sometimes does numbers instead of navigation, and toggling NumLock has no effect
Summary: NumLock OFF (to use numeric keypad for navigation) intermittently ignored by TB (and FF): sometimes does numbers instead of navigation, and toggling NumLock has no effect → NumLock OFF intermittently ignored by TB (and FF): numeric keypad sometimes does numbers instead of navigation, and toggling NumLock has no effect

Comment 10

6 years ago
Changing product so that the right people might see this.
Component: Message Compose Window → Editor
Product: Thunderbird → Core
Version: 13 → 13 Branch

Comment 11

6 years ago
Just for fun, can you try changing the keyboard to see if it helps?

Updated

6 years ago
Component: Editor → Widget: Win32
(Reporter)

Comment 12

6 years ago
I finally changed keyboards, and so far, the problem has not manifested itself.
(Reporter)

Comment 13

6 years ago
Ok. Even with the new keyboard, I still have the problem.
(Reporter)

Comment 14

6 years ago
888222444666

Very frustrating. I have been using the numeric keypad for navigation for as long as I have been using x86 computers. When this problem manifests itself, I have to switch to the dedicated arrow keys to scroll around in a web page.

Why do I use the numeric keypad instead of the dedicated keys? With my middle finger on the 5 key, I can reach all of the keypad navigation keys without moving my hand. When I use the dedicated arrow keys, I have to move my hand to press Home or End. Are you still wondering why this matters? All of the hand movement slows me down. I guess I'm going to have to figure out how to do everything in Mutt and Lynx.

Comment 15

6 years ago
I have had this same problem in several versions of Firefox, but I have never experienced it in Thunderbird. As a person who never, ever uses the middle keypad, only the one that doubles as numeric, it is extremely frustrating. Reinstalling Firefox didn't help, but when I wiped my system and reinstalled Windows 7 that fixed the problem, even though I migrated my original Firefox profile to the new installation. Doing so also solved my inability to play Flash videos. HOWEVER, today both problems suddenly returned: in Firefox the number keys on the numeric keypad enter digits even though the NumLock light is off, and Flash videos on Vimeo and YouTube no longer play. This is using Firefox 18.0.2 on Windows 7 64-bit (earlier on 32-bit).

One quirk that may help track down the problem is that Firefox doesn't behave *exactly* as if NumLock is down: if NumLock is really down, all the keys on the numeric keypad type in their printer characters, but when NumLock is up Firefox types in the printed characters for all the numbers, but the punctuation keys on the numeric keypad behave as if NumLock is down.

Another quirk is that before installing a clean version of Windows, global hotkeys would not work while Firefox was the active (foreground) application. For example, on my Start menu is a shortcut (.lnk) file that assigns the global shortcut Ctrl+Shift+D to running the Command Prompt. Thus, at any time, no matter what application I'm working in (aside from the secure desktop reached via Ctrl+Alt+Del), pressing that key combination will start Command Prompt if it's not running, or switch to it if it is running. However, when the foreground application was Firefox and the bug was manifesting itself, pressing this key combination has no effect whatsoever. If I pressed Alt+Tab to switch to another application, pressing Ctrl+Shift+D would then switch to the Command Prompt window as expected. However, after clean installs of Windows and Firefox that problem went away, and is still gone even after the Flash and NumLock bugs reappeared.

Comment 16

6 years ago
Let me add additional details in that it still happens:
* in Firefox 19.0
* in both normal mode (add-ins active) and safe mode (add-ins disabled)
* with different profiles (including the default, vanilla one)
* regardless of which Firefox window or pane has the focus (e.g. it affects scrolling or entering data in a form on a web page, in the Address and Search boxes on the toolbar, in dialog boxes such as File Open and those provided by add-ins, and when trying to navigate Firefox's menus)

I would be happy to allow someone to remotely access my system to do some debugging here, if they have the skill to debug it but can't reproduce the bug on their own system.

What if anything can we do to get attention paid to this bug?

Comment 17

6 years ago
SOLVED: The problem turned out to be a "feature" in Webroot SecureAnywhere anti-virus, which can be turned off using instructions in "WSA Forces NumLock On - Webroot Community" (http://community.webroot.com/t5/Webroot-SecureAnywhere-Internet/WSA-Forces-NumLock-On/ta-p/21630).

Updated

a year ago
Component: Widget: Win32 → Other
Priority: -- → P3
Product: Core → External Software Affecting Firefox
Whiteboard: [AV:Webroot SecureAnywhere]
Version: 13 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.