Add capability to get screen size in devicemanagerADB

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
6 years ago
5 years ago

People

(Reporter: ahal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
It is possible to get the screen resolution with devicemanagerSUT, but not devicemanagerADB. This is needed to detect invalid screen sizes for reftests.
I think it should be possible to get this information with the screencap utility on ICS-based devices.

http://a-more-common-hades.blogspot.ca/2012/01/screenshot-command.html

Not sure of a good way of doing this on 2.2/2.3, there are some ideas here but I have to confess I don't really like any of them: 

http://stackoverflow.com/questions/2807070/screenshot-of-the-nexus-one-from-adb

Since this functionality is really only needed for B2G (AFAIK), I might suggest just not supporting it for older devices.
(Reporter)

Comment 2

6 years ago
Ok, I'll take a look. I'm trying out http://stackoverflow.com/questions/7527459/android-device-screen-size first, though it says it doesn't work on all devices.
(Reporter)

Updated

6 years ago
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
(In reply to Andrew Halberstadt [:ahal] from comment #2)
> Ok, I'll take a look. I'm trying out
> http://stackoverflow.com/questions/7527459/android-device-screen-size first,
> though it says it doesn't work on all devices.

Yep, I can confirm this.
(Reporter)

Updated

6 years ago
Assignee: ahalberstadt → nobody
Status: ASSIGNED → NEW
(Reporter)

Comment 4

5 years ago
Found in triage. I don't know that this is something we can do without making some kind of extensive library. There doesn't seem to be a pressing need for it either, so resolving.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.