Closed Bug 772656 Opened 9 years ago Closed 9 years ago

End text selection when switching tabs

Categories

(Firefox for Android Graveyard :: Text Selection, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox15 verified, firefox16 verified, firefox17 verified)

VERIFIED FIXED
Firefox 16
Tracking Status
firefox15 --- verified
firefox16 --- verified
firefox17 --- verified

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
For performance reasons, let's kill the active selection if we switch tabs.
Attachment #640810 - Flags: review?(mark.finkle)
Comment on attachment 640810 [details] [diff] [review]
patch


>diff --git a/mobile/android/chrome/content/browser.js b/mobile/android/chrome/content/browser.js

>   uninit: function sh_uninit() {
>     Services.obs.removeObserver(this, "Gesture:SingleTap", false);
>     Services.obs.removeObserver(this, "Window:Resize", false);
>+    Services.obs.removeObserver(this, "Tab:Selected", false);
>     Services.obs.removeObserver(this, "after-viewport-change", false);
>   },

Cleanup: removeObserver does not have a third param. You can remove those.
Attachment #640810 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/cfc62f5ab57d
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Comment on attachment 640810 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): this should be part of the text selection mass uplift (bug 695173), but was fixed after the roll-up patch in that bug was created
User impact if declined: starting text selection on a different tab can be slow
Testing completed (on m-c, etc.): landed on m-c 7/10
Risk to taking this patch (and alternatives if risky): low risk 
String or UUID changes made by this patch: n/a
Attachment #640810 - Flags: approval-mozilla-aurora?
Attachment #640810 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Uplifted to aurora as part of a roll-up patch:
https://hg.mozilla.org/releases/mozilla-aurora/rev/2fb0a358eaf6
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.