ICS on HDPI phone shows ugly tab button, broken design affecting urlbar and menu button

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
Theme and Visual Design
VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: bnicholson, Assigned: sriram)

Tracking

({regression})

unspecified
Firefox 16
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox15 verified, firefox16 verified, firefox17 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 640845 [details]
screenshot
(Reporter)

Comment 1

6 years ago
This is on a Droid RAZR (which has a physical menu button).
(Assignee)

Comment 2

6 years ago
Created attachment 641140 [details] [diff] [review]
Patch

This patch (finally!) moves the menu button to the right. If there is a menu button present, a different browser_toolbar_menu is loaded.

Note: We need newer resources from Ian for:
tabs normal/pressed buttons, tabs normal/pressed buttons with tail, menu buttons, menu normal/pressed state buttons, tab new normal/pressed buttons.

Currently mdpi/hdpi + ICS + s/w menu button will have an ugly texture for tabs button.
Attachment #641140 - Flags: review?(mark.finkle)
(Assignee)

Comment 3

6 years ago
Created attachment 641141 [details] [diff] [review]
Patch (2/2): Refactor XHDPI

I added "drawable-xhdpi-v11" under the impression that xhdpi run only ICS (only Nexus was there then).
But, in the future, there is a possibility that xhdpi may run gingerbread. In which case we will fail.
Hence I've moved the generic (and gingerbread specific) resources to drawable-xhpi/ and left the honeycomb+ resources in drawable-xhdpi-v11/
Now the contents of these folders look the same like drawable/ and drawable-hdpi/
Attachment #641141 - Flags: review?(mark.finkle)
(Assignee)

Comment 4

6 years ago
(In reply to Sriram Ramasubramanian [:sriram] from comment #3)
> Created attachment 641141 [details] [diff] [review]
> Patch (2/2): Refactor XHDPI
> 
> I added "drawable-xhdpi-v11" under the impression that xhdpi run only ICS
> (only Nexus was there then).
> But, in the future, there is a possibility that xhdpi may run gingerbread.
> In which case we will fail.
> Hence I've moved the generic (and gingerbread specific) resources to
> drawable-xhpi/ and left the honeycomb+ resources in drawable-xhdpi-v11/
> Now the contents of these folders look the same like drawable/ and
> drawable-hdpi/

Note: We need new "gingerbread" like icons for alert_* and ic_menu_* in drawable-xhdpi/. They are now copied from drawable-xhdpi-v11/ and are honeycomb+ specific.
Summary: ICS on HDPI phone shows ugly tab button → ICS on HDPI phone shows ugly tab button, broken design affecting urlbar and menu button
Comment on attachment 641140 [details] [diff] [review]
Patch

Lot's of additions and renames. Make sure all the possibles are tested. Make sure you clobber when landing.
Attachment #641140 - Flags: review?(mark.finkle) → review+
Attachment #641141 - Flags: review?(mark.finkle) → review+
(In reply to Mark Finkle (:mfinkle) from comment #5)
> Lot's of additions and renames. Make sure all the possibles are tested. Make
> sure you clobber when landing.

As a favor to mergers, please include a note in the commit message (like "Android clobber needed") so we know to clobber before landing this on other branches too.  Thanks!

Updated

6 years ago
Blocks: 769237

Updated

6 years ago
Keywords: regression
(Assignee)

Comment 7

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/7826903ddbf2
http://hg.mozilla.org/integration/mozilla-inbound/rev/82acb91724a1

This needs clobbering.

Comment 8

6 years ago
Will this resolve the presence of a S/W menu button in the top right-hand corner on the Galaxy S III?
(Assignee)

Comment 9

6 years ago
Oh yes! This will fix Galaxy S III -- XHDPI + ICS + h/w menu button.
https://hg.mozilla.org/mozilla-central/rev/7826903ddbf2
https://hg.mozilla.org/mozilla-central/rev/82acb91724a1
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 773550

Updated

6 years ago
Duplicate of this bug: 773762

Updated

6 years ago
Attachment #641140 - Flags: approval-mozilla-aurora+

Updated

6 years ago
Attachment #641141 - Flags: approval-mozilla-aurora+

Updated

6 years ago
Assignee: nobody → sriram
https://hg.mozilla.org/releases/mozilla-aurora/rev/2d9ab7fbd680
https://hg.mozilla.org/releases/mozilla-aurora/rev/479756495eed
status-firefox15: --- → fixed
status-firefox16: --- → fixed
Target Milestone: --- → Firefox 16

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
status-firefox16: fixed → verified
status-firefox17: --- → verified
You need to log in before you can comment on or make changes to this bug.