Last Comment Bug 772717 - [adbe 3298955] Flash 11.3 crashes [@ F1942785704_____________________ ]
: [adbe 3298955] Flash 11.3 crashes [@ F1942785704_____________________ ]
Status: RESOLVED FIXED
[Flash-11.3][startupcrash]
: crash
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: unspecified
: x86 Windows 7
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 18:22 PDT by Benjamin Smedberg [:bsmedberg]
Modified: 2012-08-27 13:28 PDT (History)
9 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Benjamin Smedberg [:bsmedberg] 2012-07-10 18:22:25 PDT
Sample report:

https://crash-stats.mozilla.com/report/index/5bc7696d-1046-4402-ae25-895ee2120711

More reports:

https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A16.0a1&version=Firefox%3A15.0a2&query_search=signature&query_type=exact&query=F1942785704_____________________&reason_type=contains&range_value=1&range_unit=weeks&hang_type=any&process_type=any&do_query=1&signature=F1942785704_____________________

Full mainthread stack for this particular report was:

0|0|NPSWF32_11_3_300_262.dll|F1942785704_____________________|F1503904915______________________________________________________________________|188|0x0 0|1|NPSWF32_11_3_300_262.dll|F_33540839_________________|F_987173644______________________________________________________|316|0x7 0|2|NPSWF32_11_3_300_262.dll|F_2068343557________|F_987173644______________________________________________________|288|0x4 0|3|NPSWF32_11_3_300_262.dll|F1942853272_____________|||0x7 0|4|NPSWF32_11_3_300_262.dll|F670213680__________________|F_987173644______________________________________________________|1125|0x14 0|5|NPSWF32_11_3_300_262.dll|F110704195______________________|||0x7 0|6|NPSWF32_11_3_300_262.dll|F1183674311___________________________________|F1463397329_______________________________________|322|0xe 0|7|NPSWF32_11_3_300_262.dll|F1954011561_____________________________|F1463397329_______________________________________|3014|0x6 0|8|NPSWF32_11_3_300_262.dll|F1341112214_____________________________________|F1463397329_______________________________________|3461|0x8 0|9|NPSWF32_11_3_300_262.dll|F_115065918___________________|F855043634__________________________________________________________________________|2814|0xd 0|10|NPSWF32_11_3_300_262.dll|F1546913566_____________________________________|F855043634__________________________________________________________________________|3894|0x4 0|11|NPSWF32_11_3_300_262.dll|F1187989989____________________________________________|F855043634__________________________________________________________________________|351|0x1b 0|12|user32.dll|InternalCallWinProc|||0x22 0|13|user32.dll|GetRealWindowOwner|||0x53 0|14|user32.dll|DispatchClientMessage|||0x4a 0|15|user32.dll|__fnDWORD|||0x23 0|16|ntdll.dll|KiUserCallbackDispatcher|||0x2d 0|17|ntdll.dll|KiUserApcDispatcher|||0x47 0|18|NPSWF32_11_3_300_262.dll|F_1378698112______________________________________________________________________________________________________|F_2029912020__________________________________________________|130|0x28 0|19|NPSWF32_11_3_300_262.dll|F1340445149________________________________________________________________________________________________________|F_2029912020__________________________________________________|313|0xc 0|20|NPSWF32_11_3_300_262.dll|F_1228158002_____________________________________________|F_1566722509______________________________________________|361|0xc 0|21|NPSWF32_11_3_300_262.dll|F_2027074603__________________________________________________________________________|F1888528923___________________________________________________________________________________|37001|0xd 0|22|NPSWF32_11_3_300_262.dll|F733812712___________________________________________________________________|F_1797730831____________________________________________________|876|0x10 0|23|NPSWF32_11_3_300_262.dll|F_1452439315________________________________________________|F_1797730831____________________________________________________|1077|0xb 0|24|NPSWF32_11_3_300_262.dll|F575366301_________________________________________________|F_1797730831____________________________________________________|355|0x12 0|25|NPSWF32_11_3_300_262.dll|F104094930________________________________________________________________________|F_773115345_________________________________________________________|809|0x17 0|26|NPSWF32_11_3_300_262.dll|F_514503617_______________________________________________________|F_773115345_________________________________________________________|768|0x16 0|27|NPSWF32_11_3_300_262.dll|F423511446________________________________________________________________|F_1618895074_________________________________________________________|287|0x19 0|28|NPSWF32_11_3_300_262.dll|F1929844899___________________________________________________|F_934466540________________________________________________________|932|0x32 0|29|||||0x1db2e218 0|30|||||0x58166a4 0|31|NPSWF32_11_3_300_262.dll|F1174624935______________________________________________________|F_1429371691_________________________________________________________|176|0x21 0|32|NPSWF32_11_3_300_262.dll|F1459877691________________________________________________|F_934466540________________________________________________________|789|0x13 0|33|NPSWF32_11_3_300_262.dll|F_171706881________________________________________________|F_934466540________________________________________________________|879|0x14 0|34|NPSWF32_11_3_300_262.dll|F137121405____________________________________________________________________________________________________|F_1204515399________________________________________________________|280|0x8 0|35|NPSWF32_11_3_300_262.dll|F_1452439315________________________________________________|F_1797730831____________________________________________________|1075|0x25 0|36|NPSWF32_11_3_300_262.dll|F575366301_________________________________________________|F_1797730831____________________________________________________|355|0x12 0|37|NPSWF32_11_3_300_262.dll|F_966691389_____________________________|F1992084690______________________________________________________________|179|0x19 0|38|NPSWF32_11_3_300_262.dll|F_479902471____________________________________________________________________________________________________________|F1653964854_________________________________________________________|1806|0xe 0|39|NPSWF32_11_3_300_262.dll|F_1669242301________________________________________________________________________________________________________________________|F1653964854_________________________________________________________|1580|0x12 0|40|NPSWF32_11_3_300_262.dll|F704828765______________________________________________________________________________________________________________________________|F1653964854_________________________________________________________|1419|0xd 0|41|NPSWF32_11_3_300_262.dll|F_1545169798______________________________________________________________________________________________________________________________________|F1653964854_________________________________________________________|1388|0x12 0|42|NPSWF32_11_3_300_262.dll|F_1746476057________________________________________________________________________________________________________________________|F1653964854_________________________________________________________|2413|0x18 0|43|NPSWF32_11_3_300_262.dll|F_343812605__________________________________________________________________________|F315223226___________________________________________|2682|0x38 0|44|NPSWF32_11_3_300_262.dll|F_1427811943________________________|F1463397329_______________________________________|1840|0x14 0|45|NPSWF32_11_3_300_262.dll|F1546913566_____________________________________|F855043634__________________________________________________________________________|4314|0xe 0|46|NPSWF32_11_3_300_262.dll|F478792776_____________________________________|F855043634__________________________________________________________________________|3245|0x11 0|47|NPSWF32_11_3_300_262.dll|NPP_HandleEvent|F1563043398___________________________________________________________________|1876|0x13 0|48|FlashPlayerPlugin_11_3_300_262.exe||||0xcf64
Comment 1 Jeromie Clark 2012-07-16 18:05:55 PDT
This callstack is unfortunately too generic to be actionable.  We need URLs and/or steps to reproduce to proceed.
Comment 2 Marcia Knous [:marcia - use ni] 2012-07-17 10:36:34 PDT
Currently there are no URLs found for this signature as well as no comments to lead us to something useful in order to repro.
Comment 3 Marcia Knous [:marcia - use ni] 2012-07-25 11:06:33 PDT
Loading the vimeo site on nightly and rapidly switching back and forth between full screen produces this crash consistently for me using Flash .268

1. Load Vimeo
2. Use context menu to switch into full screen
3. Mouse click in Flash content area and switch back and forth.
4. After about 4 times it crashes consistently.

https://crash-stats.mozilla.com/report/index/bp-ff469da3-623e-42bd-9ea2-5f8c32120725 
https://crash-stats.mozilla.com/report/index/bp-08180ad5-7dd7-4c0e-a0ff-d057c2120725

Windows Vista machine, 32 bit OS, 2 GB RAM, 2.80 GHz

  Graphics

        Adapter Description
        NVIDIA GeForce 8800 GTX

        Vendor ID
        0x10de

        Device ID
        0x0191

        Adapter RAM
        768

        Adapter Drivers
        nvd3dum nvwgf2um,nvwgf2um

        Driver Version
        8.17.13.142

        Driver Date
        5-15-2012

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (7.0.6002.18592)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (NVIDIA GeForce 8800 GTX) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)

        GPU Accelerated Windows
        1/1 Direct3D 10

        AzureBackend
        direct2d
Comment 4 Marcia Knous [:marcia - use ni] 2012-07-30 07:41:55 PDT
This showed up on the explosive report - https://crash-analysis.mozilla.com/rkaiser/2012-07-29/2012-07-29.firefox.15.explosiveness.html and it still occurring with .268.
Comment 5 Jeromie Clark 2012-07-30 12:45:06 PDT
Thanks.  It would be helpful to know whether or not the crash occurs with protected mode disabled, and/or if it occurs with Hardware Acceleration disabled.  In the meantime, I'm trying to track down a similar configuration to repro on.
Comment 6 Jeromie Clark 2012-07-30 12:47:20 PDT
This is Adobe bug 3298955
Comment 7 Marcia Knous [:marcia - use ni] 2012-07-31 12:10:00 PDT
#13 top crash in Beta at the moment.
Comment 8 Marcia Knous [:marcia - use ni] 2012-08-20 11:39:18 PDT
The signature summary shows that this crash seems to be confined to 11.3.x version - I don't see any 11.4 versions in the list.
Comment 9 smadayag 2012-08-27 13:28:03 PDT
code change in FP 11.4, Dolores.  11.4.402.265 shipped to the public 8/21.  closing resolved.

Note You need to log in before you can comment on or make changes to this bug.