Last Comment Bug 772743 - Add pref to prevent top level widget going fullscreen in b2g desktop client
: Add pref to prevent top level widget going fullscreen in b2g desktop client
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Chris Pearce (:cpearce)
:
:
Mentors:
Depends on:
Blocks: 684620
  Show dependency treegraph
 
Reported: 2012-07-10 22:03 PDT by Chris Pearce (:cpearce)
Modified: 2012-07-13 20:24 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Bug 772743 - Add pref to not make the widget fullscreen when entering fullscreen. Set it to true for b2g desktop client. (2.30 KB, patch)
2012-07-10 22:10 PDT, Chris Pearce (:cpearce)
mounir: review+
Details | Diff | Splinter Review

Description Chris Pearce (:cpearce) 2012-07-10 22:03:30 PDT
For the b2g desktop client we'd like a pref to toggle that prevents the top-level widget from going fullscreen when content enters dom fullscreen mode. This is to stop the B2G desktop client window (and thus content) from taking up the entire screen of the host OS; the content should instead resize to completely fill the client window.

Without this, the app running in the b2g desktop client gets impression that the (emulated) device's screen spontaneously grows when entering fullscreen, which obviously doesn't happen on physical hardware!

cjones is vehement that he'd prefer a pref rather than just relying on #defines here...
Comment 1 Chris Pearce (:cpearce) 2012-07-10 22:10:14 PDT
Created attachment 640919 [details] [diff] [review]
Bug 772743 - Add pref to not make the widget fullscreen when entering fullscreen. Set it to true for b2g desktop client.

Add pref to prevent the top level widget entering fullscreen. Set it to true for b2g desktop client.
Comment 2 Mounir Lamouri (:mounir) 2012-07-13 01:35:04 PDT
Comment on attachment 640919 [details] [diff] [review]
Bug 772743 - Add pref to not make the widget fullscreen when entering fullscreen. Set it to true for b2g desktop client.

Review of attachment 640919 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the comment added.

::: dom/base/nsGlobalWindow.cpp
@@ +4477,5 @@
>    // Set this before so if widget sends an event indicating its
>    // gone full screen, the state trap above works.
>    mFullScreen = aFullScreen;
>  
> +  if (!Preferences::GetBool("full-screen-api.ignore-widgets", false)) {

Can you add a quick comment explaining why you are checking that pref here so reader will not have to go to b2g.js to understand (which might not be obvious because nothing says this is related to b2g).
Comment 3 Chris Pearce (:cpearce) 2012-07-13 03:22:58 PDT
Landed with comment added:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e3f2d02b21b9
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-13 20:24:19 PDT
https://hg.mozilla.org/mozilla-central/rev/e3f2d02b21b9

Note You need to log in before you can comment on or make changes to this bug.