If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser says it's running full screen when I tell it to run full screen

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: Michael, Unassigned)

Tracking

16 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120710030551

Steps to reproduce:

Make browser full screen, for example, by clicking on a full screen icon on a photo in Facebook.


Actual results:

1) The browser goes full screen.
2) The browser overlays the page with a huge message saying that it's now full screen, and offering a way to block the behavior.
3) I know it's full screen.  I just told it to go full screen.  The message is not helpful, interferes with page viewing, and is annoying.


Expected results:

No message.  If I tell the browser to go full screen, it should do so without telling me that it did so.
Michael: A screenshot of what you are seeing would help - also on facebook I cannot seem to locate a photo that has a full screen icon.
(Reporter)

Comment 2

5 years ago
You can get the icon on any photo, I think.  Here are two screenshots, one with the icon clearly marked, and the other with the result.  Note that Facebook sometimes gives only certain people certain features, so if it doesn't work on your account, try someone else's.
(Reporter)

Comment 3

5 years ago
Created attachment 641283 [details]
Click on this icon to get Facebook in full screen and get the notice on top

Click on this icon to get Facebook in full screen and get the notice on top
(Reporter)

Comment 4

5 years ago
Created attachment 641284 [details]
The notice on top is what tells you that Firefox is now in full screen.
Hi Michael. Looks like this issue hasn't been addressed for quite a while. Sorry about that!  The current full screen notice allows you to check a box to always allow full screen for that domain. So the annoying notice only has to appear for your once for Facebook. 

You can turn off this feature with about:config and the full-screen-api.approval-required option; see this support page: https://support.mozilla.org/en-US/questions/937742
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.