Content of drop-down lists like the history in location bar blinks on secondary monitor with hardware acceleration enabled

RESOLVED DUPLICATE of bug 800701

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 800701
6 years ago
6 years ago

People

(Reporter: Rafał, Unassigned)

Tracking

13 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 2 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 641042 [details]
ScreenRec_ 20120711_1556_59.rar

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

System: Windows 7
Two monitors:
[secondary(1280x1024), left side][primary(1920x1080), right side]

Firefox opened in left(secondary) monitor.


Actual results:

When I opened Address bar drop-down list and moved cursor to select address i see flashing. I attached screen record to show what is wrong


Expected results:

Address bar drop-down list should show addresses without flashing

Comment 1

6 years ago
Is it a recent issue? Since Firefox 13 update? Flash 11.3 update?

In addition, try:
* in safe mode, see http://kb.mozillazine.org/Firefox_Safe_Mode
* with a new Firefox profile, see https://support.mozilla.org/en-US/kb/Managing-profiles
(Reporter)

Comment 2

6 years ago
So,
I working on new version of Firefox, my firefox version is 13.

I had done all steps:
- Run firefox in safe mode: i still see this problem.
- Run firefox with a new Firefox profile: At the beginning everything was ok because drop-down list was empty and "the new tab page" was also empty. I opened some websides like: "www.interia.pl, www.onet.pl, www.ing.pl, www.era.pl, www.firefox.pl, www.komputronik.pl, www.vobis.pl, www.samsung.com, www.google.pl, www.t-mobile.pl". Now, after that i have full drop-down URL addresses list and some websides in new card tab. This problem was always in new card tab. I thing that something was wrong with focus between url drop-down list and windows on "new tab page". Sometimes everything works properly but sometimes is terrible. When I heve this problem then I must move firefox window to right primary monitor where is ok, if I back this window to left secondary monitor then I have this issue again.
(Reporter)

Comment 3

6 years ago
Created attachment 642920 [details]
secondary screen record

I saw another thing. This is problem with options in drop-down list for "remember password" pop up window. I have the same flashing as was described for address field.

Comment 4

6 years ago
Upload your screenshots as jpeg/png please, don't zip them. Or use a free imagehoster like http://imgur.com/
(Reporter)

Comment 5

6 years ago
(In reply to Loic from comment #4)
> Upload your screenshots as jpeg/png please, don't zip them. Or use a free
> imagehoster like http://imgur.com/

This is zipped avi file. You can see what happen on move, I affraid that picture can't show you flashing effect.

Updated

6 years ago
Attachment #642920 - Attachment is patch: false
Attachment #642920 - Attachment mime type: text/plain → application/octet-stream

Comment 6

6 years ago
Could you paste here the graphics section of about:support please.

In addition, try with hardware acceleration disabled (Options > Advanced > General, restart FF).

Comment 7

6 years ago
Created attachment 643908 [details]
Video capture 1 (20120711_1556_59.webm)

I converted your videos into WebM, it's more simple to play without downloading the file.

I'm not completely sure, but bug 775503 seems to be similar to yours. 
What do you think?
Attachment #641042 - Attachment is obsolete: true
Attachment #642920 - Attachment is obsolete: true

Comment 8

6 years ago
Created attachment 643910 [details]
Video capture 2 (20120717_1447_58.webm)

Updated

6 years ago
Attachment #643910 - Attachment description: Video capture 1 (20120717_1447_58.webm) → Video capture 2 (20120717_1447_58.webm)
(Reporter)

Comment 9

6 years ago
When Firefox Menu > Options > Advanced > General > Use hardware acceleration option is disabled everything works properly. So I think that problem is with implementation for hardware acceleration.

Comment 10

6 years ago
So HWA seems to be involved. Could you paste the graphics section of about:support please.
(Reporter)

Comment 11

6 years ago
Created attachment 644250 [details]
Hardware acceleration option

This option must be unchecked (disabled) to turn off the malfunction of the program

Comment 12

6 years ago
Yes, we know, HWA is hardware acceleration. :)

Could you copy and paste in your post the graphics section of about:support (array with the list of GPUs, drivers, Direct2D etc), please?
It's important to know which GPU is involved.
(Reporter)

Comment 13

6 years ago
I'll give you the full HWA specification on Monday morning.
(Reporter)

Comment 14

6 years ago
HP 6000 PRO
CPU: Pentium(R) Dual Core E5500 2.8 GHz
RAM: 4GB (4 x 1GB) DDR3
Chipset: Intel Q43 Express
GPU: Integrated Intel Graphics Media Accelerator 4500 HD (system see this as: Intel(R) Q45/Q43 Express Chipset)
 
DISPLAY
left (secondary) - HP L1950
right (primary) - HP Compaq LA2306x
(Reporter)

Comment 15

6 years ago
Motherboard Name: Hewlett-Packard HP Compaq 6000 Pro SFF PC
Motherboard Chipset	Intel Eaglelake Q43

CPU Type	DualCore Intel Pentium E5500, 2800 MHz (14 x 200)
CPU (Driver):
  provider: Microsoft
  date: 2006-06-21
  Version: 6.1.7600.16385
  Signer: Microsoft Windows

Video Adapter	Intel(R) Q45/Q43 Express Chipset  (1814142 KB)
GPU Code Name	Eaglelake-Q  (Integrated 8086 / 2E12, Rev 03)
3D Accelerator	Intel GMA 4500
Display adapter (driver):
  provider: Intel Corporation
  date: 2011-02-11
  Version: 8.15.10.2302
  Signer: Microsoft Windows Hardware Compatibility Publisher
Installed Drivers	
igdumd64	8.15.10.2302
igd10umd64	8.15.10.2302
igdumdx32	8.15.10.2302
igd10umd32	8.15.10.2302

Monitor	HP Compaq LA2306 Wide LCD Monitor [NoDB]  (CNC206PG80)
  provider: HP
  date: 2010-08-23
  Version: 1.0.0.0
  Signer: Microsoft Windows Hardware Compatibility Publisher

Monitor	HP L1950 (Analog)  [19" LCD]  (CNK82611K3)
  provider: HP
  date: 2007-02-20
  Version: 1.0.0.0
  Signer: Microsoft Windows Hardware Compatibility Publisher

DirectX	DirectX 11.0
OpenGL	6.1.7600.16385 (win7_rtm.090713-1255)
(Reporter)

Comment 16

6 years ago
Created attachment 644887 [details]
OpenGL info
(Reporter)

Comment 17

6 years ago
Created attachment 644888 [details]
directX info

Comment 18

6 years ago
We don't need all these details, we just want info from about:support.

Type about:support in the location bar of Firefox, go to the graphics section/array/table, then copy it then paste it in your message (no need to attach it, just paste it). Thanks.
(Reporter)

Comment 19

6 years ago
Graphics
        Adapter DescriptionIntel(R) Q45/Q43 Express ChipsetVendor ID0x8086Device ID0x2e12Adapter RAMUnknownAdapter Driversigdumd64 igd10umd64 igdumdx32 igd10umd32Driver Version8.15.10.2302Driver Date2-11-2011Direct2D EnabledfalseDirectWrite Enabledfalse (6.1.7601.17789)ClearType ParametersClearType parameters not foundWebGL RendererGoogle Inc. -- ANGLE (Intel(R) Q45/Q43 Express Chipset) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)GPU Accelerated Windows0

Comment 20

6 years ago
Could you update the drivers of your Intel Q45/Q43 Express Chipset please, they are outdated.
Latest version: 15.17.18.64.2555 (10/19/2011)
See http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20601&ProdId=2997&lang=eng&OSVersion=Windows%207%20%2864-bit%29*&DownloadType=Drivers#
(Reporter)

Comment 21

6 years ago
I installed latest driver version from http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20601&ProdId=2997&lang=eng&OSVersion=Windows%207%20%2864-bit%29*&DownloadType=Drivers and the problem still exist.


Current "about:support":
Adapter DescriptionIntel(R) Q45/Q43 Express ChipsetVendor ID0x8086Device ID0x2e12Adapter RAMUnknownAdapter Driversigdumd64 igd10umd64 igdumdx32 igd10umd32Driver Version8.15.10.2555Driver Date10-13-2011Direct2D EnabledtrueDirectWrite Enabledtrue (6.1.7601.17789)ClearType ParametersClearType parameters not foundWebGL RendererGoogle Inc. -- ANGLE (Intel(R) Q45/Q43 Express Chipset) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)GPU Accelerated Windows1/1 Direct3D 10
        AzureBackenddirect2d

Updated

6 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
Summary: flashing Address bar drop-down list → Content of drop-down lists like the history in location bar blinks on secondary monitor with hardware acceleration enabled

Updated

6 years ago
Blocks: 775503
Duplicate of this bug: 781799
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

I can confirm this issue: sub-menus , bookmarks menu, history suggestions from the Location bar, tooltips (including from Social Api)and context menus are transparent on the second monitor on Windows 7-64 bit (with HWA on).

On the primary monitor the issue is not reproducible (regardless if the HWA is on or off)
If the HWA is off the issue is not reproducible on the second monitor either.

Please see the screencast for details:
http://screencast.com/t/zEeVcsSDzP

Setting the status of this bug to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 24

6 years ago
There is a similar bug that appeared with FF16, same issue on 2nd monitor with HWA enabled: see bug 800701.
Bug 800701 seems to be a duplicate of this one. 
In Comment 5 from Bug 800701, I see a regression window that indicates that the problem was introduced in Firefox 16. The thing is that I can reproduce this issue also on Firefox 15. It's true that between Firefox 15 and Firefox 16 the transparency issue has gotten worse. I will come back with a regressions range for this as soon as possible.
The issue seems to be intermittent and I could reproduce it ever since Firefox 4.0. Please see the screencast for more details.
http://screencast.com/t/akZhhncw2lrg

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 800701
You need to log in before you can comment on or make changes to this bug.