Closed Bug 772842 Opened 11 years ago Closed 7 years ago

The newly opened tab is not always focused when taking a speed test from a youtube fullscreen video

Categories

(Toolkit :: Video/Audio Controls, defect)

14 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ioana_damy, Unassigned)

References

Details

(Keywords: regression)

Firefox 14.0 beta 12: 20120710123126
Flash: 11.3.300.265

STR:
1. Load http://www.youtube.com/ in the browser.
2. Start playing a video in fullscreen.
3. Right-click the video and select the "Take speed test" option.

The video is paused and http://www.youtube.com/my_speed is opened in a new tab.
Sometimes the video exits fullscreen and the speed test tab is focused, other times the video is paused but it stays in fullscreen. There is no indication that the new tab was opened although it was.

This issue also reproduces on the latest Nightly and Aurora builds.

It doesn't reproduce on Firefox 4.0 so it's a regression, but I don't have a regression range yet.
Mozregression range:

m-c
good=2010-10-21
bad=2010-10-22
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4788083ce564&tochange=b6c9c4833613

Suspected bug:
Bug 596094 - windowed plugin subclass is dropped after entering/exiting full screen in flash
Keywords: regression
Blocks: 596094
20160604131506 Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
20160609130607 Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

I have tested your issue on latest FF release 47.0 and latest Nightly build and could not reproduce it with the steps you provided.
Is this still reproducible on your end ? If yes, can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
Flags: needinfo?(ioana_damy)
Closing this as works-for-me as roxana cannot reproduce the issue and the reporter has not responded in over 3 weeks.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(ioana_damy)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.