Add "apply" button to color selection dialog in Editor

VERIFIED DUPLICATE of bug 90670

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 90670
18 years ago
17 years ago

People

(Reporter: mozilla, Assigned: cmanske)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I'm doing a project where i'm taking a web page and color-coding certain 
words and phrases for an editor to change later.  It kinda sucks having to 
constantly hit the little text color icon for the color box to pop up.

In fact, it would be GREAT if that color selector box could just stay open 
and I could hit an "apply" button to apply the changes, highlight the next 
bit, hit apply again...

You know what an apply button's for ;)  So that's it for this bug.  Thanks.

Comment 1

18 years ago
Personally, I'd prefer if we didn't have apply, cancel or ok.  Picking a color
that is not on the palette should happen by clicking "other..." and bringing up
a dialog where the user can ok, cancel, apply.

A better option would be a floating palette to choose from... that sounds best
to me!
Assignee: beppe → cmanske
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: other → All
Hardware: Other → All
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 2

18 years ago
Why isn't the color widget on the toolbar a popup menu of frequently-used 
colors (with `Other ...' at the bottom), rather than a button? That way you 
could change the color with a single drag, instead of having to open the 
colorpicker window at all.
(Assignee)

Comment 3

18 years ago
If all you want to do is repeat the same color, you can do that easily now:
Select some text, use colorpicker, and set the color.
Select the next text you want with same color, and use Shift+click on the 
toolbar colorpicker button (text button, of course), and the previous color will
be repeated. 
Yes, that UI is not really discoverable. We hope to expose tricks like this with
a "tip of the day" feature and better help documentation.
Making the colorpicker more popup-menu-like is covered by bug 90670
Target Milestone: mozilla1.1 → mozilla1.0
(Assignee)

Comment 4

18 years ago
I don't think floating palettes are a good idea for most of our users, who are
not professional web authors. I think the discussion of the "tip of the day"
to expose what we already have (Shift+Click on color), and comments about making
the color picker more like a popup are sufficient to resolve this bug.
I'll dup it to 90670 so we can access the comments made here.

*** This bug has been marked as a duplicate of 90670 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

18 years ago
Sorry, I'm confused-- what does being a professional web author have to do with 
it?  I'm not a professional by any means, but a floating color picker would be 
very useful.  What's the downside?  Are you worried "apply" would confuse people 
or something?
(Assignee)

Comment 6

18 years ago
Yes. Our minimal user testing suggests that floating palettes are not the best
UI for most users. Thus we stay with the modal dialog model for most of our UI
(Insert Character/Symbol is the exception, but that is probably used by more
advanced users.)
The push has been to make the colorpicker more like a menu popup to make it 
easier to use.

Comment 7

18 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.