PTO notifications not being sent

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
--
major
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: kev, Assigned: solarce)

Tracking

Details

(Reporter)

Description

6 years ago
I've submitted a couple PTO requests in the last 48hrs, and have clicked the "cc: me" checkbox before submitting the request. In both cases I have not received the PTO notification and, in checking with my colleagues who were cc'd on the request, they did not receive the notification either. Since this is the way we're supposed to be filing PTO, the notifications should work, and we should be checking the backlog for when this stopped.

Please fix asap.

Thanks,

kev
Assignee: server-ops → server-ops-webops
Component: Server Operations → Server Operations: Web Operations
QA Contact: phong → cshields
Assignee: server-ops-webops → bburton

Updated

6 years ago
Group: infra
(Assignee)

Comment 1

6 years ago
After some testing, caught the following error in /var/log/maillog 

Jul 12 10:59:32 intranet1 sendmail[28255]: q6CHxWQI028255: from=apache, size=388, class=0, nrcpts=5, msgid=<201207121759.q6CHxWQI028255@intranet1.webapp.scl3.mozilla.com>, relay=apache@localhost
Jul 12 10:59:32 intranet1 sendmail[28255]: q6CHxWQI028255: q6CHxWQJ028255: DSN: Joel Aguilera <jaguilera@mozilla.com, jvandeven@mozilla.com... Unbalanced '<'
Jul 12 10:59:32 intranet1 sendmail[28256]: q6CHxW6r028256: from=<>, size=3049, class=0, nrcpts=1, msgid=<201207121759.q6CHxWQJ028255@intranet1.webapp.scl3.mozilla.com>, proto=ESMTP, daemon=MTA, relay=mrapp-intranet01.mozilla.org [127.0.0.1]
Jul 12 10:59:32 intranet1 sendmail[28255]: q6CHxWQJ028255: to=apache, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31412, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (q6CHxW6r028256 Message accepted for delivery)
Jul 12 10:59:32 intranet1 sendmail[28257]: STARTTLS=client, relay=smtp.mozilla.org., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jul 12 10:59:32 intranet1 sendmail[28257]: q6CHxW6r028256: to=sysalerts@mozilla.org, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=33312, relay=smtp.mozilla.org. [63.245.216.69], dsn=2.0.0, stat=Sent (Ok: queued as 895F7F290E)

Still investigating
The error says the Joel Aguilera address is missing a trailing ">" character, even though it has a "<" in it to delimit an address.  Sounds like the app is missing this when generating the RCPT TO lines for the SMTP transaction when it sends them out.
(Assignee)

Comment 3

6 years ago
The issue was with the following block in config.php, it was missing a >

$notified_people = array(
  "Jill Van De Ven <jvandeven@mozilla.com>",
  "Joel Aguilera <jaguilera@mozilla.com",
  "Doris Coleman <dcoleman@mozilla.com>"
);

I fixed it to be

$notified_people = array(
  "Jill Van De Ven <jvandeven@mozilla.com>",
  "Joel Aguilera <jaguilera@mozilla.com>",
  "Doris Coleman <dcoleman@mozilla.com>"
);

Because this file is not kept in revision control, it's difficult to determine when/why the change was made, but I've confirmed the app is working after making the fix and going a graceful restart of httpd
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

6 years ago
The current PTO app is unmaintained and this functionality is not easily monitored without user feedback.

A new PTO app will be launching soon and should address some of the maintenance and monitoring issues
(Reporter)

Comment 5

6 years ago
Thanks folks. I'm concerned that a lot of folks filed and no one was notified. Does it make sense to let people know?
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.