Generate new results for comparative browsers on a regular basis

RESOLVED WONTFIX

Status

Testing Graveyard
Eideticker
RESOLVED WONTFIX
6 years ago
a year ago

People

(Reporter: wlach, Unassigned)

Tracking

Trunk
x86_64
Linux

Details

Right now we're generating results for browsers that don't change often (if ever) in the Eideticker dashboard. We should change this so that we just gather data for such browsers once per test (to establish a baseline) and only gather updated data when the browser or test changes.
So we turned off testing competing browsers in the dashboard, but we do actually want these benchmarks for comparative purposes. Changing the title to match what we want here.

This would not be that terribly difficult to implement. Eideticker already supports running benchmarks against all browsers on Android. All we need is to add the concept of "baseline" results to the dashboard code (both in terms of storing them on the backend and displaying them on the front end). Maybe a few days to a week's worth of work for me, possibly slightly longer for someone less familiar with the eideticker code.
Summary: Don't need to generate new results for comparative browsers every day → Need a way to generate new results for comparative browsers on an irregular basis
We have support for this internally now, just need to create new jobs to make it happen.
Summary: Need a way to generate new results for comparative browsers on an irregular basis → Generate new results for comparative browsers on a regular basis
Duplicate of this bug: 943500

Comment 4

a year ago
Eideticker has been discontinued, see bug 1361056
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX

Updated

a year ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.