Ghost articles in overview section of Localization Dashboard

RESOLVED FIXED in 2013Q1

Status

support.mozilla.org
Localization
P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Assigned: rrosario)

Tracking

unspecified
2013Q1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=l10n p=2 s=2013.6)

(Reporter)

Description

5 years ago
* French:
The Preview section tells that 10 articles (256-246) need to be updated or translated while the other sections say there are 2 articles that need to be updated and 7 to be translated, so there's one ghost article.
See https://support.mozilla.org/fr/localization

* Spanish:
The Preview section tells that 31 articles (256-225) need to be updated or translated while the other sections say there are 18 articles that need to be updated and one to be translated, so there are 12 ghost articles.
See https://support.mozilla.org/es/localization

It has something to do with redirects that don't show up in locales where they were not localized (see bug 767788). The overall KB article count depends now on the locale.
(Assignee)

Comment 1

5 years ago
Sounds like we need to discount redirects when they are in the not translated state.
Target Milestone: --- → 2012.14
(Assignee)

Comment 2

5 years ago
Hmmm, but it is weird because there were only 3 untranslated redirects in Spanish. Need to investigate further.
(Reporter)

Comment 3

5 years ago
I think I found the French ghost article: https://support.mozilla.org/fr/kb/quest-ce-que-browserid-comment-ca-marche/history. It's an article with only reviewed (deferred) revisions. It should have show up in the Untranslated section.

Another odd thing is that its content, summary and keyword fields are empty when you try to edit it.
(Assignee)

Comment 4

5 years ago
First step is to figure out where the problem is then fixing it. Guesstimating at 2pts.
Whiteboard: u=contributor c=l10n p=2
Kadir said anything in the 2012.14 sprint that wasn't IA related should be a P3. Making it so.
Priority: -- → P3
Assignee: nobody → rdalal
(Assignee)

Updated

5 years ago
Assignee: rdalal → mcooper
(Assignee)

Comment 6

5 years ago
This isn't making it in time for 2012.14. Dropping to the next sprint and we can discuss during planning if it sticks or not.
Target Milestone: 2012.14 → 2012.15
(Assignee)

Updated

5 years ago
Assignee: mcooper → nobody
(Assignee)

Comment 7

5 years ago
Dropped out of sprint during planning.
Target Milestone: 2012.15 → 2012.16
(Assignee)

Comment 8

5 years ago
We have too many points in 2012.16 already. This is falling out.
Target Milestone: 2012.16 → 2012.17
(Reporter)

Comment 9

5 years ago
It hasn't been re-targeted.
(Assignee)

Updated

5 years ago
Whiteboard: u=contributor c=l10n p=2 → u=contributor c=l10n p=2 s=2013.backlog
(Assignee)

Updated

5 years ago
Target Milestone: 2012.17 → 2013Q1
Moving into next sprint. Bug 782752 might be a dupe of this one.
Whiteboard: u=contributor c=l10n p=2 s=2013.backlog → u=contributor c=l10n p=2 s=2013.6
(Assignee)

Comment 11

5 years ago
Scoobidiver, is this still an issue? If so, can you give us updated examples? :)

Thanks!
(Reporter)

Comment 12

5 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #11)
> Scoobidiver, is this still an issue? If so, can you give us updated examples? :)
I still see eight articles not updated or localized (288-80) in the Spanish dashboard while only one that needs updates and three in pending review that need a first approved revision so four ghost articles: https://support.mozilla.org/es/localization
(Reporter)

Comment 13

5 years ago
See the end of comment 0 for an explanation.
(Assignee)

Comment 14

5 years ago
(In reply to Scoobidiver from comment #13)
> See the end of comment 0 for an explanation.

If I am understanding this correctly, what we need to do is filter out redirects from the total count. Is that right?
(Assignee)

Updated

5 years ago
Summary: Ghost articles in Preview section of Localization Dashboard → Ghost articles in overview section of Localization Dashboard
(Reporter)

Comment 15

5 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #14)
> If I am understanding this correctly, what we need to do is filter out
> redirects from the total count. Is that right?
... and the localized count if you don't want scores higher than 100% for French or Dutch. But in that case, you may have a very rare situation where there's a manual redirect that needs to be localized and a score of 100%.
The ideal would be to filter out redirects in the localized and total counts, once the localized revision of an English redirect is localized. You will have a total count dependent of the locale and the localized status of redirects.

If you don't want to spend too much time on that, implement the first solution, not the ideal one.
(Assignee)

Comment 16

5 years ago
(In reply to Scoobidiver from comment #15)

OK, if I filter out redirects from the overview counts I get:

Total docs: 278
Up-to-date "es" docs: 273
Up-to-date "fr" docs: 245

Does that sound right? That doesn't change the gap in French and only improves Spanish by 1.
(Assignee)

Comment 17

5 years ago
OK, it looks like the most of the ghost articles are actually articles that have a translation but none of the revisions are approved:
https://support.mozilla.org/es/kb/Consejos%20de%20B%C3%BAsqueda/history
https://support.mozilla.org/es/kb/Configurar%20Firewall%20de%20Windows/history

Those are the 2 ghost articles left in Spanish. The other 3 no up to date appear under "Needs Review".

So... It looks like translations that only have deferred revisions (none approved or waiting for review) are falling through the cracks. They should probably appear in the "Untranslated" readout.
(Reporter)

Comment 18

5 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #16)
> Total docs: 278
> Up-to-date "es" docs: 273
> Up-to-date "fr" docs: 245
> Does that sound right? That doesn't change the gap in French and only
> improves Spanish by 1.
There are four articles too many in French (34 how-to or troubleshooting articles to update or localized and three to review for the first time) and two ghost articles in Spanish (https://support.mozilla.org/es/kb/configure-windows-firewall-allow-firefox-access and https://support.mozilla.org/es/kb/how-use-popular-search-suggestions-in-search-bar probably corrupted in Spanish).
(Assignee)

Comment 19

5 years ago
(In reply to Scoobidiver from comment #18)
> (https://support.mozilla.org/es/kb/configure-windows-firewall-allow-firefox-
> access and
> https://support.mozilla.org/es/kb/how-use-popular-search-suggestions-in-
> search-bar probably corrupted in Spanish).

Looks like we found the same two articles :). These don't have any approved translations so they should appear in the Needs Translation section. Right?
(Assignee)

Updated

5 years ago
Assignee: nobody → rrosario
(Reporter)

Comment 20

5 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #19)
> Looks like we found the same two articles :). These don't have any approved
> translations so they should appear in the Needs Translation section. Right?
Yes.

The redirect filter-out and the display in Needs Translation section of articles without approved revision will fix the Spanish dashboard but not the French one (33 declared as not up-to-date in the count but 37 to update).
(Assignee)

Comment 21

5 years ago
(In reply to Scoobidiver from comment #20)
> (In reply to Ricky Rosario [:rrosario, :r1cky] from comment #19)
> > Looks like we found the same two articles :). These don't have any approved
> > translations so they should appear in the Needs Translation section. Right?
> Yes.
> 
> The redirect filter-out and the display in Needs Translation section of
> articles without approved revision will fix the Spanish dashboard but not
> the French one (33 declared as not up-to-date in the count but 37 to update).

The French dashboard has the opposite of ghosts? How is that?

I guess we can start by making these fixes and then seeing what else is busted.
(Assignee)

Comment 22

5 years ago
Scoobidiver: I looked at the French dashboard and I am counting 34 articles listed as needing up date vs the 33 indicated in the overview section. Hopefully I am off by one somewhere and we are good. Otherwise, we'll keep digging after I land these changes.
(Assignee)

Comment 23

5 years ago
In a pull request:

https://github.com/mozilla/kitsune/pull/1220
(Reporter)

Comment 24

5 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #22)
> Scoobidiver: I looked at the French dashboard and I am counting 34 articles
> listed as needing up date
I counted the three in Needs Review that don't have an approved revision. So there's only one article too many.
(Assignee)

Comment 25

5 years ago
This landed on master:
https://github.com/mozilla/kitsune/commit/7762caa3ebeda7eab570a4065bf4d58959371607

Now redirects won't be counted in the overview stats and all articles without approved translations will show up under Untranslated. A side effect of that is that some articles might show up in both "Needs Review" and "Untranslated". If is too annoying, feel free to file a bug but the SQL query is nasty and I couldn't figure out how to do it in this round.
(Assignee)

Comment 26

5 years ago
Deployed to prod now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 27

5 years ago
(In reply to Scoobidiver from comment #24)
> So there's only one article too many.
Still confirmed. There are 31 articles to update and the overview counts only 30 articles to update. It's OK in Firefox OS and Firefox for Android, so it's in desktop Firefox.

After approving each article one by one on allizom, https://support.allizom.org/fr/kb/definir-firefox-navigateur-defaut-fonctionne-pas hasn't changed the count. It's caused by either https://support.mozilla.org/fr/kb/definir-firefox-navigateur-defaut-fonctionne-pas or https://support.mozilla.org/fr/kb/definir-firefox-navigateur-defaut-fonctionne-pas. But I don't see anything wrong with them.
(Reporter)

Comment 28

5 years ago
(In reply to Scoobidiver from comment #27)
> https://support.mozilla.org/fr/kb/definir-firefox-navigateur-defaut-
> fonctionne-pas
I meant https://support.mozilla.org/en-US/kb/setting-firefox-default-browser-does-not-work
(Reporter)

Comment 29

5 years ago
I localized https://support.allizom.org/pt-PT/kb/Definir%20o%20Firefox%20como%20o%20navegador%20por%20omiss%C3%A3o%20n%C3%A3o%20funciona and it has counted one in the overview so it seems https://support.mozilla.org/fr/kb/definir-firefox-navigateur-defaut-fonctionne-pas is broken.
(Assignee)

Comment 30

5 years ago
(In reply to Scoobidiver from comment #29)
> I localized
> https://support.allizom.org/pt-PT/kb/
> Definir%20o%20Firefox%20como%20o%20navegador%20por%20omiss%C3%A3o%20n%C3%A3o%
> 20funciona and it has counted one in the overview so it seems
> https://support.mozilla.org/fr/kb/definir-firefox-navigateur-defaut-
> fonctionne-pas is broken.

I seeing that one up to date and not listed in:
https://support.allizom.org/fr/localization

So that seems to be working right. I am confused, what's the issue then?
(Reporter)

Comment 31

5 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #30)
> I seeing that one up to date and not listed in:
> https://support.allizom.org/fr/localization
Because I approved it to see the count hasn't changed. Delete the latest revision of https://support.allizom.org/fr/kb/definir-firefox-navigateur-defaut-fonctionne-pas, check the count, approved a new one and check again the count.
(Assignee)

Comment 32

5 years ago
(In reply to Scoobidiver from comment #31)
> Because I approved it to see the count hasn't changed. Delete the latest
> revision of
> https://support.allizom.org/fr/kb/definir-firefox-navigateur-defaut-
> fonctionne-pas, check the count, approved a new one and check again the
> count.

I just created a new en-US revision that is ready for l10n and the count dropped from 252 to 251 on the dashboard...
https://support.allizom.org/en-US/kb/setting-firefox-default-browser-does-not-work/history
(Assignee)

Comment 33

5 years ago
(In reply to Scoobidiver from comment #31)

Yeah, the test revision you created wasnt marked as ready for l10n.
(Reporter)

Comment 34

5 years ago
I approved the French revision and this time the count has incremented by one: 251 to 252.

(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #33)
> Yeah, the test revision you created wasnt marked as ready for l10n.
It was. See https://support.allizom.org/en-US/kb/setting-firefox-default-browser-does-not-work/revision/36551. I created https://support.allizom.org/en-US/kb/setting-firefox-default-browser-does-not-work/revision/38418 later.
So, we are good?
(Reporter)

Comment 36

5 years ago
(In reply to Kadir Topal [:atopal] from comment #35)
> So, we are good?
No there's still something wrong (articles not counted instead of ghost articles) at least for the German (4 articles), French and Japanese (one article) dashboards (es, it are OK). For the French case, https://support.mozilla.org/fr/kb/definir-firefox-navigateur-defaut-fonctionne-pas is not counted.
(In reply to Scoobidiver from comment #36)
> (In reply to Kadir Topal [:atopal] from comment #35)
> > So, we are good?
> No there's still something wrong (articles not counted instead of ghost
> articles)

You mean not counted as being localized but included in the total? Meaning that you can't reach 100% localization?
(Reporter)

Comment 38

5 years ago
(In reply to Kadir Topal [:atopal] from comment #37)
> You mean not counted as being localized but included in the total?
The total is for all locales and correct. Some articles are considered localized for the localized count but are not (show up in one of the dashboard sections).

> Meaning that you can't reach 100% localization?
No. In German for instance, if you update every articles except the four affected ones, you will reach 100%. Then each update of the remaining will keep the dashboard at 100% (no 101% for instance).
Scoobi, so this articles is outdated, but shows as localized on the dashboard? https://support.mozilla.org/fr/kb/definir-firefox-navigateur-defaut-fonctionne-pas
(Reporter)

Comment 40

5 years ago
(In reply to Kadir Topal [:atopal] from comment #39)
> Scoobi, so this articles is outdated, but shows as localized on the
> dashboard?
> https://support.mozilla.org/fr/kb/definir-firefox-navigateur-defaut-
> fonctionne-pas
Yes and no. It shows up as not localized in the dashboard (see https://support.mozilla.org/fr/localization/needing-updates), which is true (see https://support.mozilla.org/fr/kb/definir-firefox-navigateur-defaut-fonctionne-pas/edit), but is counted as localized in the coverage percentage (that's what I found by troubleshooting in allizom).
You need to log in before you can comment on or make changes to this bug.