[Fx15Beta] Cross-post Nick's Memory blog post

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: lforrest, Assigned: mlavine)

Tracking

Details

(Reporter)

Description

7 years ago
Hi there - we need help with a quick blog cross-post next Thursday morning, July 19th PST. Will post link here once we have it.
(Reporter)

Updated

7 years ago
Summary: [Fx14] Cross-post Nick's Memory blog post → [Fx15Beta] Cross-post Nick's Memory blog post
Laura, when I did a similar blog post for Firefox 7 I posted it on my blog when FF7 entered beta, and the Hacks re-post happened when FF7 was finally released.  Should we do the same timetable here?  I think it would be more effective than publishing the same content on two different blogs at the same time.
(Reporter)

Comment 2

7 years ago
(In reply to Nicholas Nethercote [:njn] from comment #1)
> Laura, when I did a similar blog post for Firefox 7 I posted it on my blog
> when FF7 entered beta, and the Hacks re-post happened when FF7 was finally
> released.  Should we do the same timetable here?  I think it would be more
> effective than publishing the same content on two different blogs at the
> same time.

Good question. We'd like to post it during the Beta timeframe since the Beta audience are most likely the ones who may experience improvements. So timing wise it's a good fit, and supporting blog posts starting from Beta is a current best practice (not sure how it worked during the Fx7 timeframe). 

Note, we'll continue the memory story during the GA timeframe too.
Assignee: nobody → havi
(Reporter)

Comment 3

7 years ago
Havi generously volunteered to post the tl;dr version of this post on the Hacks blog Thursday morning. Thanks Havi!

Comment 5

7 years ago
Hi Havi- I sent some suggested edits to anything we post on an official channel. 

Mark - Can you work w/Havi to get a short version of this w/the positive framing on Hacks?
(Assignee)

Comment 6

7 years ago
Hi Havi - It'd be great if we could edit the post in the following way before 7am (below). We'd really like to frame this as "memory improvements" versus "leaky Firefox." Also, we'd like to reference the post rather than directly link to it. Any way to make the edits to Hacks before 7am so we don't spin a negative news cycle before the release is live? 

...
Editor’s note: This is a short excerpt from Nicholas Nethercote’s personal blog. Nicholas is a programmer from Melbourne, Australia, who works for Mozilla on improving the quality of software. For an in-depth look at this memory optimization project (the results of which are in Firefox 15 Beta) you’ll want to click over to the complete post. Here’s the good news in a nutshell:

Optimizing Memory Usage for Add-ons

"Over the past year, Mozilla has made great progress in reducing Firefox’s memory consumption.  However, the excessive memory consumption caused by add-ons with memory leaks has remained an ongoing problem.

Firefox 15 fixes that problem.  We have confirmed, via in-house testing and from real-world telemetry data, that it prevents the vast majority of leaks that occur in existing add-ons.

Users who upgrade to Firefox 15 won’t have to upgrade their add-ons to see the benefits.  While it is hard to predict the effect of this improvement on any individual user, many users should experience greatly reduced memory consumption, particularly on long browsing sessions.  This should result in better performance, fewer pauses, and fewer crashes.

Mozilla’s MemShrink efforts are ongoing.  We have various projects in the pipeline that aim to further reduce Firefox’s memory consumption, and help users understand better how Firefox is using memory. "
(Reporter)

Comment 7

7 years ago
Mark - Seems like Havi can't post this. Can you work with Janet or Havi to find someone with access who can?
Assignee: havi → mlavine
(Assignee)

Comment 8

7 years ago
Post went up yesterday: https://hacks.mozilla.org/2012/07/firefox-15-optimizing-memory/

Thanks for everyone's help
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Component: hacks.mozilla.org → Mozilla Hacks
Product: Websites → Mozilla Developer Network

Updated

2 years ago
Product: Mozilla Developer Network → Developer Engagement
You need to log in before you can comment on or make changes to this bug.