Last Comment Bug 773089 - Do not use large menus on Gingerbread devices.
: Do not use large menus on Gingerbread devices.
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: Theme and Visual Design (show other bugs)
: 16 Branch
: ARM Android
: -- normal (vote)
: Firefox 16
Assigned To: Chris Peterson [:cpeterson]
:
Mentors:
: 739074 760357 766861 767713 (view as bug list)
Depends on:
Blocks: 770079
  Show dependency treegraph
 
Reported: 2012-07-11 16:32 PDT by Chris Peterson [:cpeterson]
Modified: 2012-11-13 06:10 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified
verified


Attachments
menu-large-v11.patch (2.53 KB, patch)
2012-07-11 16:35 PDT, Chris Peterson [:cpeterson]
sriram.mozilla: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Chris Peterson [:cpeterson] 2012-07-11 16:32:44 PDT
I was hitting the following exception when trying to open the browser menu. The Gingerbread Galaxy Note thinks it is a "large" device, but fails to load the menu-large resources.

java.lang.NullPointerException
	at org.mozilla.gecko.BrowserApp.onPrepareOptionsMenu(BrowserApp.java:592)
	at android.app.Activity.onPreparePanel(Activity.java:2196)
	at org.mozilla.gecko.GeckoApp.onPreparePanel(GeckoApp.java:595)
	at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java:359)
	at com.android.internal.policy.impl.PhoneWindow.onKeyDownPanel(PhoneWindow.java:602)
	at com.android.internal.policy.impl.PhoneWindow.onKeyDown(PhoneWindow.java:1276)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchKeyEvent(PhoneWindow.java:1850)
	at android.view.ViewRoot.deliverKeyEventToViewHierarchy(ViewRoot.java:2813)
	at android.view.ViewRoot.handleFinishedEvent(ViewRoot.java:2774)
	at android.view.ViewRoot.handleMessage(ViewRoot.java:1992)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:130)
	at android.app.ActivityThread.main(ActivityThread.java:3691)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:912)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:670)
	at dalvik.system.NativeStart.main(Native Method)
Comment 1 Chris Peterson [:cpeterson] 2012-07-11 16:35:08 PDT
Created attachment 641253 [details] [diff] [review]
menu-large-v11.patch

Do not use "large" menus on Gingerbread devices.
Comment 2 Sriram Ramasubramanian [:sriram] 2012-07-11 18:02:24 PDT
Comment on attachment 641253 [details] [diff] [review]
menu-large-v11.patch

Review of attachment 641253 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me.
Please remove the logs :)
r+ with that change.
Comment 3 Chris Peterson [:cpeterson] 2012-07-12 09:10:02 PDT
https://hg.mozilla.org/mozilla-central/rev/69f5207c57c8
Comment 4 Sriram Ramasubramanian [:sriram] 2012-07-12 15:56:46 PDT
Comment on attachment 641253 [details] [diff] [review]
menu-large-v11.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Note! Really? How can it a LARGE device on gingerbread?
User impact if declined: Note running GB will crash.
Testing completed (on m-c, etc.): Landed on m-c on 07/12
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.

The comments in the patch were removed, while pushing the code to m-c. Same will be done for aurora too.
Comment 5 Alex Keybl [:akeybl] 2012-07-12 16:04:41 PDT
Comment on attachment 641253 [details] [diff] [review]
menu-large-v11.patch

[Triage Comment]
Basically no risk, so no reason to wait on uplift.
Comment 6 Matt Brubeck (:mbrubeck) 2012-07-13 13:52:31 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/9368a54926a5 accidentally landed with this bug number; it is actually from related bug 773735.
Comment 7 Chris Peterson [:cpeterson] 2012-07-13 19:22:17 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/7140e39a6427
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-07-13 20:21:48 PDT
https://hg.mozilla.org/mozilla-central/rev/9368a54926a5
Comment 9 Scoobidiver (away) 2012-07-14 06:12:41 PDT
*** Bug 766861 has been marked as a duplicate of this bug. ***
Comment 10 Chris Peterson [:cpeterson] 2012-07-14 17:12:52 PDT
(In reply to Ryan VanderMeulen from comment #8)
> https://hg.mozilla.org/mozilla-central/rev/9368a54926a5

btw, cset 9368a54926a5 is for a different bug which inadvertently listed this bug's number. I landed this bug's fix on m-c two days ago in cset 69f5207c57c8.
Comment 11 Scoobidiver (away) 2012-07-16 14:22:35 PDT
*** Bug 760357 has been marked as a duplicate of this bug. ***
Comment 12 Aaron Train [:aaronmt] 2012-07-25 12:21:59 PDT
WFM via HTC Nexus One (Android 2.3.4)
Comment 13 Scoobidiver (away) 2012-08-17 14:19:52 PDT
*** Bug 767713 has been marked as a duplicate of this bug. ***
Comment 14 Scoobidiver (away) 2012-11-13 06:10:18 PST
*** Bug 739074 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.