Mozilla randomly starts using ~95% CPU time when nothing is happening.

RESOLVED WORKSFORME

Status

()

Core
Networking: Cache
--
major
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: dylang, Assigned: asa)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I seem to get random spots where browser starts using 95% of CPU time.  This is
with build 2001042013.  I'll add more when I find a way to reliably reproduce
it.  So far I've noticed it 2 times in the past 24 hours.

Comment 1

17 years ago
Is this happening when a dialog box is waiting on the screen?

I notice that under Linux that Moz has pegged the CPU whenever it puts up a 'do
you want this image / cookie' prompt.  That's been happening practically
forever, so there's probably already a bug filed on that problem.
(Reporter)

Comment 2

17 years ago
No, this has only happened with the 0420 build (previous was 0316).  I noticed
it because the system seemed more slugish than usual, so I loaded top.  dnetc
and Moz were fighting it out, with Moz winning.

When I loaded my mail client 20 minutes ago, I noticed the same effect.  Again
it was Moz.  3 windows open, no dialogs, nothing loading.  Just spinning away
and away at the CPU.
(Reporter)

Comment 3

17 years ago
Steps to reproduce with build 2001042708:

Load http://www.gibsonhax0r.net/media/winblows.html
Right click image, choose "View Image"
Watch the CPU usage peg.

I think this is related to the throbber not stoping, despite the "Image loaded
in 0.16s" being in the status area..
(Reporter)

Comment 4

17 years ago
Another way to reprduce (including in 0.9!) is to look at an image, click back,
then view the image again (like in a dir of images you are looking at).  I think
it's some interaction between newcache and libpr0n, since you have to view the
image once before the CPU is sucked.
Component: Browser-General → Networking: Cache
(Reporter)

Comment 5

17 years ago
This behaviour seems gome in 2001052606.  Marking closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.