widget ui doesn't get updated after customization of toolbar

RESOLVED WONTFIX

Status

Add-on SDK
General
P2
normal
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: Claude Nobs, Unassigned)

Tracking

(Depends on: 1 bug, {dev-doc-needed, regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120707040207

Steps to reproduce:

a) create & install a very simple builder (jetpack) addon that displays a dynamic text instead of an icon (using port API & a small html file) (see: https://builder.addons.mozilla.org/addon/1021651/latest/).
b) open toolbar "customize..." dialog
c) close dialog with or without modifying toolbar


Actual results:

during & after "customize..." the addon displays the default text until one of its update event handlers is fired


Expected results:

the text that was last set should be displayed

i don't know if the addon has to register a listener for this, but i didn't find anything in the API reference. i think the old XUL addons API is : 
gNavToolbox.addEventListener("aftercustomization", &func, false);
gNavToolbox.addEventListener("beforecustomization", &func, false);
but then gNavToolbox is not defined in jetpack context

Updated

6 years ago
Assignee: nobody → evold
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(In reply to Claude Nobs from comment #0)

Thanks for the report Claude, as far as I can tell these customization events shouldn't be changing the widget at all..  I don't understand what the use case for changing the content during these events would be at the moment.
Priority: -- → P2
After talking to Irakli, it looks like firing the 'attach' event again would solve this use case, which is similar to the use case of opening a new window.
note: this is related to bug 634137
We got a similar report for MemChaser lately:
https://github.com/mozilla/memchaser/issues/140

I have checked this more and this is a regression between 15.0 beta and Aurora (16.0a2). So something broke the Add-on SDK.
Keywords: regression, regressionwindow-wanted

Comment 5

6 years ago
I tested with https://addons.mozilla.org/en-us/firefox/addon/memchaser/

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/131961e5e0d1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120611224425
Bad:
http://hg.mozilla.org/mozilla-central/rev/733994f12c53
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120612024525
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=131961e5e0d1&tochange=733994f12c53


Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/da773d72a620
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120611150101
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ca716959ca2b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120611152325
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=da773d72a620&tochange=ca716959ca2b

Updated

6 years ago
Blocks: 736695
Keywords: regressionwindow-wanted
Can we get an update for this bug?
Erik, the thing is that widget iframes are detached and re-attached to the DOM when customization starts. In order to fix that, we will have to modifify platform code:
  http://mxr.mozilla.org/mozilla-central/source/toolkit/content/customizeToolbar.js#276

If I remember corrrectly, `aToolbarItem` here, is `node` from widget code over here:
  https://github.com/mozilla/addon-sdk/blob/master/lib/sdk/widget.js#L705

And when you move an iframe in DOM, its document always gets reloaded.
bug 634137 allows to automatically re-apply content scripts when a new document is loaded in widgets.
(In reply to Alexandre Poirot (:ochameau) from comment #7)
> Erik, the thing is that widget iframes are detached and re-attached to the
> DOM when customization starts. In order to fix that, we will have to
> modifify platform code:
>  
> http://mxr.mozilla.org/mozilla-central/source/toolkit/content/
> customizeToolbar.js#276

No bug for this yet?
(In reply to Erik Vold [:erikvold] [:ztatic] from comment #8)
> No bug for this yet?

No platform bug yet, but I think there is multiple jetpack bugs related to this issue.
I thought that everything would have been fixed with matteo's work for new widget in firefox, but now, I don't know what is the status of this.
Assignee: evold → nobody

Comment 10

5 years ago
Added keyword dev-doc-needed because the example at https://addons.mozilla.org/en-US/developers/docs/sdk/latest/dev-guide/tutorials/annotator/widget.html needs to include workaround code for this bug, or at least mention it.
Keywords: dev-doc-needed
When Australis lands widget will be deprecated so we won't be working on this.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Comment 12

4 years ago
bug 936623 looks to be handling the update of docs.
You need to log in before you can comment on or make changes to this bug.