Parent Element's Font-size of 0 prevents children from being scrollable via mousewheel

RESOLVED DUPLICATE of bug 422132

Status

()

RESOLVED DUPLICATE of bug 422132
6 years ago
6 years ago

People

(Reporter: globexdesigns, Unassigned)

Tracking

15 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20120712 Firefox/15.0a2
Build ID: 20120712042007

Steps to reproduce:

When an element has a font-size of 0, any children elements inside it which have font-size set to inherit will not be scrollable via the mousewheel.

Here is a test case: http://jsfiddle.net/PqYpd/

If JsFiddle doesn't work, here is the code to reproduce the issue:

<span style="font-size:0">
    <ul style="height:80px;overflow:auto;">
        <li>One</li>
        <li>Two</li>
        <li>Three</li>
        <li>Four</li>
        <li>Five</li>
        <li>Six</li>
        <li>Seven</li>
        <li>Eight</li>
        <li>Nine</li>
        <li>Ten</li>
    </ul>
</span>


Actual results:

Mousewheel did not scroll the <ul> container.


Expected results:

Mousewheel should scroll the <ul> container.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422132
You need to log in before you can comment on or make changes to this bug.