Last Comment Bug 773397 - Disable pdf.js prior to FF15 beta 5
: Disable pdf.js prior to FF15 beta 5
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: PDF Viewer (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Brendan Dahl [:bdahl]
: Mihaela Velimiroviciu (:mihaelav)
Mentors:
Depends on:
Blocks: 786012
  Show dependency treegraph
 
Reported: 2012-07-12 12:37 PDT by Alex Keybl [:akeybl]
Modified: 2013-12-27 14:23 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
disable pdf.js (1.28 KB, patch)
2012-07-27 10:54 PDT, Brendan Dahl [:bdahl]
gavin.sharp: review+
gavin.sharp: approval‑mozilla‑beta+
Details | Diff | Splinter Review
disable pdf.js (1.80 KB, patch)
2012-08-14 14:27 PDT, Brendan Dahl [:bdahl]
no flags Details | Diff | Splinter Review

Description Alex Keybl [:akeybl] 2012-07-12 12:37:10 PDT
Asa let us know that we'll keep pdf.js on the test channels till at least FF16's release, so we'll need to disable pdf.js prior to FF15's release.
Comment 1 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-18 16:53:59 PDT
Assigning this to Brendan for now - Brendan are you the best person to have as the point person for disabling this when the time comes? If not, please re-assign to the person who will be.
Comment 2 Brendan Dahl [:bdahl] 2012-07-19 08:55:12 PDT
I can create a patch to disable it, though I don't have commit access.  To disable it will require changing one line(http://mxr.mozilla.org/mozilla-beta/source/browser/app/profile/firefox.js#1165) to true.
Comment 3 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-24 17:27:08 PDT
(In reply to Brendan Dahl from comment #2)
> I can create a patch to disable it, though I don't have commit access.  To
> disable it will require changing one
> line(http://mxr.mozilla.org/mozilla-beta/source/browser/app/profile/firefox.
> js#1165) to true.

If you can prepare the patch, and get it reviewed, we can flag this as checkin-needed in time for the last beta.
Comment 4 Brendan Dahl [:bdahl] 2012-07-27 10:54:24 PDT
Created attachment 646630 [details] [diff] [review]
disable pdf.js
Comment 5 Alex Keybl [:akeybl] 2012-07-30 12:39:38 PDT
I think it would be more prudent to disable for our second to last beta, just in case.
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-14 11:09:03 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/7488058a7c3f
Comment 7 Ed Morley [:emorley] 2012-08-14 13:00:17 PDT
Backed out at Gavin's request for browser_pdfjs_main.js failures:
https://tbpl.mozilla.org/?tree=Mozilla-Beta&rev=7488058a7c3f

https://hg.mozilla.org/releases/mozilla-beta/rev/a9b08621c0f3
Comment 8 Brendan Dahl [:bdahl] 2012-08-14 14:27:48 PDT
Created attachment 651889 [details] [diff] [review]
disable pdf.js
Comment 9 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-14 14:40:20 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/aff8c2ba16dd
Comment 10 Mihaela Velimiroviciu (:mihaelav) 2012-08-17 03:59:24 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0

PDF.js was successfully disabled in Firefox 15.0beta5: "Preview in Firefox" option is not available for handling PDFs.
Comment 11 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-08-29 07:14:31 PDT
When updating pdf.js 0.4.11 for Firefox 17, it lacked pdfjs/content/web/images/toolbarButton-fullscreen.png. And this lacking is continued in aurora 17.

At nightly 18, I sent a patch (bug 784718), and the patch will be checked-in within days.
Should we check-in it for aurora 17 too? Although disable pdf.js on aurora 17 by this bug's patch, I think that we keep a source-tree as cleanly. This filling does not cause any regression.
Comment 12 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-08-29 07:15:41 PDT
(In reply to OHZEKI Tetsuharu [:saneyuki_s] from comment #11)
> When updating pdf.js 0.4.11 for Firefox 17, it lacked
> pdfjs/content/web/images/toolbarButton-fullscreen.png. And this lacking is
> continued in aurora 17.
> 
> At nightly 18, I sent a patch (bug 784718), and the patch will be checked-in
> within days.
> Should we check-in it for aurora 17 too? Although disable pdf.js on aurora
> 17 by this bug's patch, I think that we keep a source-tree as cleanly. This
> filling does not cause any regression.

Opps! I mistake the bug number.
Please read as following:
bug 784718 -> bug 786219
Comment 13 Alex Keybl [:akeybl] 2012-08-29 11:03:09 PDT
(In reply to OHZEKI Tetsuharu [:saneyuki_s] from comment #11)
> When updating pdf.js 0.4.11 for Firefox 17, it lacked
> pdfjs/content/web/images/toolbarButton-fullscreen.png. And this lacking is
> continued in aurora 17.
> 
> At nightly 18, I sent a patch (bug 784718), and the patch will be checked-in
> within days.
> Should we check-in it for aurora 17 too? Although disable pdf.js on aurora
> 17 by this bug's patch, I think that we keep a source-tree as cleanly. This
> filling does not cause any regression.

PDF.js is now disabled in FF17 (bug 786012). No need to uplift.
Comment 14 Ed Morley [:emorley] 2012-08-30 06:34:12 PDT
Gavin, is there a bug filed (/plan) for the Nightly-only xpcshell failures on aurora due to aff8c2ba16dd ?
Comment 15 Ed Morley [:emorley] 2012-08-30 06:36:15 PDT
(In reply to Ed Morley [:edmorley] from comment #14)
> Gavin, is there a bug filed (/plan) for the Nightly-only xpcshell failures

Just noticed that the aurora commit landed with the wrong bug number, I'll move this discussion to bug 786012.

Note You need to log in before you can comment on or make changes to this bug.