If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser fails to load any page

VERIFIED DUPLICATE of bug 76293

Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 76293
17 years ago
13 years ago

People

(Reporter: tracy, Assigned: gordon)

Tracking

Trunk
mozilla0.9
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: would like for 0.9)

(Reporter)

Description

17 years ago
seen on linux commercial 2001-04-24-05-trunk

-launch browser
home page isn't loaded
-click on throbber
nothing loads
-enter a URL
nothing loads
(Reporter)

Updated

17 years ago
Keywords: smoketest
(Reporter)

Comment 1

17 years ago
note: windows commercial 2001-04-24-06-trunk works fine 
      still waiting on mac build
could this be our old friend the cache corruption bug?

Comment 3

17 years ago
I don't see this problem on my Netscape build on Linux from 9pm last night
Chris - can you help with narrowing this down? thanks, Vishy

Comment 5

17 years ago
I've seen this randomly on linux, it's probably cache-related like Pinkerton said.

Comment 6

17 years ago
Definitely something to do with the cache. I seen several occurences where 
pages won't load any more, normally after a crash or a debug session which 
I've ended. Deleting the profiles's newcache/_CACHE_MAP_ appears to fix the 
problem.
(Reporter)

Comment 7

17 years ago
I just loaded the same build on another linux machine....Used the same profiles 
that caused the crash on the original machine and did not have this problem.  

reducing from blocker and asking for help to clear up the smoketest machine for 
future testing...Thanks
Severity: blocker → major
Keywords: smoketest

Comment 8

17 years ago
what percentage of people are getting hit by this?
Severity: major → critical
Whiteboard: would like for 0.9
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 9

17 years ago
Please don't just delete the NewCache directory.  We need to try things in this 
order:
1) COPY the NewCache directory somewhere outside the profile directory.
1) relaunch mozilla
2) reboot the OS and then relaunch mozilla (okay, if it's really too painful you 
can skip this, but it may affect the results).
3) DELETE the NewCache directory in the profile directory (or try to) and 
relaunch mozilla.
4) COPY the copied NewCache directory back into the profile directory and 
relaunch mozilla.

If the browser works after 1, 2, or 4, the NewCache directory is not corrupt, but 
we will have narrowed the actual cause down.

Please post results to bug 76293.

Comment 10

17 years ago
I have experienced this in Build 2001042404 under the following circumstances:

Open Mozilla - somehow it crashes 
Open Mozilla again & no pages load.  

To fix this, I must first kill the Dr.Watson app on Win2K and then re-load
Mozilla.  It looks like stuff is staying in memory?
(Assignee)

Comment 11

17 years ago
Yes, that's my hypothesis.  I believe this is somehow related to open file 
descriptors to certain cache files (either left open after a crash, or previously 
opened by a another currently running instance of mozilla, as some linux users 
have reported).

That's why I've asked people to try rebooting their OS after this problem occurs; 
that should definitely close the file descriptors, and allow the disk cache to 
start working again.

Comment 12

17 years ago
asa -> gordon.
Assignee: asa → gordon
(Assignee)

Comment 13

17 years ago
This sounds very much like a dup of bug 76293.  Someone can reopen this if they 
disagree.


*** This bug has been marked as a duplicate of 76293 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 14

17 years ago
verified dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.