Huge memory usage and heap-unclassified with BananaBread

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: marco, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P2], URL)

Memory usage is ~700 MB. Heap unclassified is ~40%.
I just tried to reproduce, but on my Linux64 box the demo failed to load, citing a problem with texture compression :(

Comment 3

6 years ago
njn: Try with FF15 and above, only they have texture compression.
> njn: Try with FF15 and above, only they have texture compression.

I did!  I tried an FF16 trunk build :/

Comment 5

6 years ago
Hmm. Do compressed textures work on your system? For example

http://media.tojicode.com/webgl-samples/dds.html
> Hmm. Do compressed textures work on your system? For example
> 
> http://media.tojicode.com/webgl-samples/dds.html

Perhaps not!  I just tried that page and I got a featureless red cube.  I suspect it is meant to have a texture on it.

Comment 7

6 years ago
Yeah, I guess your machine does not support DXT texture compression. Does it work in other browsers? What GPU/drivers are you on?
Same here with Linux x64.
Tungsten Graphics, Inc -- Mesa DRI Intel(R) G45/G43  -- 2.1 Mesa 8.0.2
Here are my graphics details from about:support:

  Adapter Description
  Tungsten Graphics, Inc -- Mesa DRI Intel(R) Sandybridge Desktop

  Vendor ID
  Tungsten Graphics, Inc

  Device ID
  Mesa DRI Intel(R) Sandybridge Desktop

  Driver Version
  3.0 Mesa 8.0.2

  WebGL Renderer
  Tungsten Graphics, Inc -- Mesa DRI Intel(R) Sandybridge Desktop  -- 3.0 Mesa 8.0.2

  GPU Accelerated Windows
  0

  AzureBackend
  skia

With a Firefox 16 trunk build I get a blank red cube and about 4 FPS.  With Chrome 20 I got a blank black cube and 60 FPS on the first run;  but when I restarted and tried again it said "could not create a WebGL context".  Opera 12.00 also couldn't created a WebGL context.
The problem is the texture compression algorithm (s3tc) that isn't enabled by default with Mesa.
Nicholas, can you try running with the environment variable force_s3tc_enable=true?
Filed bug 774134 about enabling this compression algorithm by default.
force_s3tc_enable=true fixes it -- I see Lena.  I still only get 9 FPS, though.
Nathan, would you be interested in taking a look at this.
Whiteboard: [MemShrink] → [MemShrink:P2]

Comment 14

5 years ago
WFM due to OdinMonkey?
"Firefox can't find the server at www.syntensity.com." Is this demo available somewhere else? If not, we'll have to close the bug.
It's available here: https://developer.mozilla.org/it/demos/detail/bananabread

Memory usage is still high, but heap unclassified is roughly 10-12%.
The demo has changed though, now it's using asm.js.
While playing my RSS is about 720 MiB. That seems reasonable for such a complex demo. Not much else to do here, I think.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.