xul grid loses track of column count.

RESOLVED FIXED in mozilla0.9.6

Status

()

Core
XUL
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: Peter Wilson, Assigned: Eric Vaughan)

Tracking

({testcase})

Trunk
mozilla0.9.6
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

17 years ago
If you fill a grid dynamically using javascript the grid can loose track of how 
many columns it should have. This happens when no rows are to be displayed. In 
this case no row elements are present. If you then rebuild the grid with data 
present the grid has collapesed to one column and remains that way.

See attachments for example code.

Also note it is neccessary to have a dummy row in the xul to get multiple 
columns to display.
(Reporter)

Comment 1

17 years ago
Created attachment 32006 [details]
javascript used to fill grid.
(Reporter)

Comment 2

17 years ago
Created attachment 32007 [details]
XUL for grid
over to XUL
Assignee: asa → trudelle
Component: Browser-General → XP Toolkit/Widgets: XUL
QA Contact: doronr → jrgm

Comment 4

17 years ago
->evaughan
Assignee: trudelle → evaughan

Updated

17 years ago
Summary: xul grid looses track of column count. → xul grid loses track of column count.
Target Milestone: --- → mozilla0.9.3

Comment 5

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 6

17 years ago
Doesn't look like this is getting fixed before the freeze tomorrow night.
Pushing out a milestone.  Please correct if I'm mistaken.
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 7

17 years ago
-> 095
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Comment 8

17 years ago
This is fixed by my new grid code. It will land next build.
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Comment 9

17 years ago
Created attachment 52607 [details] [diff] [review]
Patch for new grid code.
(Assignee)

Comment 10

17 years ago
I patch has been made to add new grid code. The first part of the patch contains:

1) fix for box not setting parent pointer
2) changed to box to give grid more access
3) ifdefs so none of the new code is on by default to turn on define MOZ_GRID2

The new grid code is on the end of the patch but if you want really take a look
it can be found in the tree at mozilla/layout/xul/base/src/grid

Comment 11

17 years ago
Change the DEBUG_evaughan to a MOZ_GRID2.  Take the grid code, since it doesn't
need r/sr yet.  

r=hyatt
(Assignee)

Comment 12

17 years ago
Created attachment 52612 [details] [diff] [review]
new patch
(Assignee)

Comment 13

17 years ago
Created attachment 52624 [details] [diff] [review]
Ok one more time.

Comment 14

17 years ago
sr=waterson
(Assignee)

Comment 15

17 years ago
Created attachment 54100 [details] [diff] [review]
A few more ifdefs
(Assignee)

Comment 16

17 years ago
Created attachment 54145 [details] [diff] [review]
Ok the patch one again.
Comment on attachment 54145 [details] [diff] [review]
Ok the patch one again.

r=bryner
Attachment #54145 - Flags: review+

Comment 18

17 years ago
Comment on attachment 54145 [details] [diff] [review]
Ok the patch one again.

sr=hyatt
Attachment #54145 - Flags: superreview+
(Assignee)

Comment 19

17 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.