Error importing XML: unknown package Testopia::Importer

RESOLVED FIXED in 3.0

Status

Testopia
Import/Export
P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jesus Abel Hernandez, Assigned: Jesus Abel Hernandez)

Tracking

Details

(Assignee)

Description

5 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Win64; x64; Trident/5.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C)

Steps to reproduce:

Import a XML.


Actual results:

Then happend this error:
[Thu Jul 12 13:47:18 2012] [error] [client 127.0.0.1] [Thu Jul 12 13:47:18 2012] tr_importer.cgi: Can't locate object method "new" via package "Testopia::Importer" (perhaps you forgot to load "Testopia::Importer"?) at D:/bugzilla/bugzilla-4.2.1_ok/tr_importer.cgi line 103, <fh00001testplans-2012-07-12.xml> chunk 1., referer: http://localhost:22080/tr_show_product.cgi


Expected results:

It should import my new file of test cases.

I review the code and saw this in the tr_importer.cgi, line 103:
        my $importer = new Testopia::Importer;

I changed this for:
        my $importer = new Bugzilla::Extension::Testopia::Importer;


and now it seems to work... but I prefer that you review this.

thanks.
(Assignee)

Updated

5 years ago
OS: All → Windows Vista
Priority: -- → P3

Comment 1

5 years ago
Yes, your fix is correct.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Version: unspecified → 2.5

Comment 2

5 years ago
Committing to: bzr+ssh://lpsolit@gmail.com@bzr.mozilla.org/bugzilla/extensions/testopia/trunk/
modified tr_importer.cgi
Committed revision 663.
Assignee: gregaryh → jesusabel.hernandez.martin
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Summary: Error importing XML in Testopia 2.5(this value isn't into the field 'version'). → Error importing XML: unknown package Testopia::Importer

Updated

5 years ago
Target Milestone: --- → 2.6

Updated

5 years ago
Duplicate of this bug: 559577
You need to log in before you can comment on or make changes to this bug.