Last Comment Bug 773606 - XBL fastload creates XUL element before feeding proto attributes to the protoelement
: XBL fastload creates XUL element before feeding proto attributes to the proto...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XBL (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on:
Blocks: 94199
  Show dependency treegraph
 
Reported: 2012-07-13 05:35 PDT by Olli Pettay [:smaug]
Modified: 2012-07-13 14:27 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.67 KB, patch)
2012-07-13 05:52 PDT, Olli Pettay [:smaug]
enndeakin: review+
Details | Diff | Review

Description Olli Pettay [:smaug] 2012-07-13 05:35:42 PDT
nsXULElement::Create expects that it can check for example mHasClassAttribute value.
But that is just always false if the protoattributes are created after
the real DOM element.
Comment 1 Olli Pettay [:smaug] 2012-07-13 05:48:55 PDT
In practice this shouldn't matter much since the XUL element is used within XBL's not-yet-cloned content. But I'm investigating to disable using prototypes in XUL (for anything else but serializing and de-serializing) and noticed this inconsistency.
Comment 3 Olli Pettay [:smaug] 2012-07-13 14:27:05 PDT
https://hg.mozilla.org/mozilla-central/rev/be26e809e6b1

Note You need to log in before you can comment on or make changes to this bug.